aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2012-07-17 23:11:31 +0000
committerLuka Perkov <luka@openwrt.org>2012-07-17 23:11:31 +0000
commit31406b79a5a7ca5bb6d2e5ce545774e667c771fb (patch)
treef1b923e72368b639d2469d3572a1f7235dfd566f /package/kernel
parentba9bf28854ffe4fb44760d3715afcf2f2587bfc8 (diff)
downloadupstream-31406b79a5a7ca5bb6d2e5ce545774e667c771fb.tar.gz
upstream-31406b79a5a7ca5bb6d2e5ce545774e667c771fb.tar.bz2
upstream-31406b79a5a7ca5bb6d2e5ce545774e667c771fb.zip
[package] kernel/modules: dont only change loading order on IPSEC*-m, propagate this to documentation too
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32775 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netsupport.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index b4e2a425a0..5d78027efa 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -275,11 +275,11 @@ define KernelPackage/ipsec4
KCONFIG:= \
CONFIG_INET_AH \
CONFIG_INET_ESP \
- CONFIG_INET_IPCOMP \
CONFIG_INET_XFRM_MODE_BEET \
CONFIG_INET_XFRM_MODE_TRANSPORT \
CONFIG_INET_XFRM_MODE_TUNNEL \
- CONFIG_INET_XFRM_TUNNEL
+ CONFIG_INET_XFRM_TUNNEL \
+ CONFIG_INET_IPCOMP
FILES:=$(foreach mod,$(IPSEC4-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoLoad,32,$(notdir $(IPSEC4-m)))
endef
@@ -289,11 +289,11 @@ define KernelPackage/ipsec4/description
Includes:
- ah4
- esp4
- - ipcomp4
- xfrm4_mode_beet
- xfrm4_mode_transport
- xfrm4_mode_tunnel
- xfrm4_tunnel
+ - ipcomp
endef
$(eval $(call KernelPackage,ipsec4))
@@ -315,11 +315,11 @@ define KernelPackage/ipsec6
KCONFIG:= \
CONFIG_INET6_AH \
CONFIG_INET6_ESP \
- CONFIG_INET6_IPCOMP \
CONFIG_INET6_XFRM_MODE_BEET \
CONFIG_INET6_XFRM_MODE_TRANSPORT \
CONFIG_INET6_XFRM_MODE_TUNNEL \
- CONFIG_INET6_XFRM_TUNNEL
+ CONFIG_INET6_XFRM_TUNNEL \
+ CONFIG_INET6_IPCOMP
FILES:=$(foreach mod,$(IPSEC6-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoLoad,32,$(notdir $(IPSEC6-m)))
endef
@@ -329,11 +329,11 @@ define KernelPackage/ipsec6/description
Includes:
- ah6
- esp6
- - ipcomp6
- xfrm6_mode_beet
- xfrm6_mode_transport
- xfrm6_mode_tunnel
- xfrm6_tunnel
+ - ipcomp6
endef
$(eval $(call KernelPackage,ipsec6))