aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/w1-gpio-custom/Makefile
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-12-06 23:25:48 +0900
committerHauke Mehrtens <hauke@hauke-m.de>2019-12-23 01:07:23 +0100
commite242125d71cf543b3c80dfa64b62d0d53678d18a (patch)
tree30ebaa0f9cc33b4ed4e95a1cb23f1cd300d883d2 /package/kernel/w1-gpio-custom/Makefile
parent84b74bcb0d962dc192dc6c3f0ada3e0eba6fb593 (diff)
downloadupstream-e242125d71cf543b3c80dfa64b62d0d53678d18a.tar.gz
upstream-e242125d71cf543b3c80dfa64b62d0d53678d18a.tar.bz2
upstream-e242125d71cf543b3c80dfa64b62d0d53678d18a.zip
kernel: fix *-gpio-custom module unloading
Unloading and reloading the modules fails, as platform_device_put() does not release resources fully. root@OpenWrt:/# insmod i2c-gpio-custom bus0=0,18,0,5 [ 196.860620] Custom GPIO-based I2C driver version 0.1.1 [ 196.871162] ------------[ cut here ]------------ [ 196.880517] WARNING: CPU: 0 PID: 1365 at fs/sysfs/dir.c:31 0x80112158 [ 196.893431] sysfs: cannot create duplicate filename '/devices/platform/i2c-gpio.0' ... [ 197.513200] kobject_add_internal failed for i2c-gpio.0 with -EEXIST, don't try to register things with the same name in the same directory. This patch fixes it by replacing platform_device_put() to platform_device_unregister(). Fixes: da7740853715 ("i2c-gpio-custom: minor bugfix") Fixes: 3bc81edc70e8 ("package: fix w1-gpio-custom package (closes #6770)") Signed-off-by: Sungbo Eo <mans0n@gorani.run> (cherry picked from commit a22b7a60d98836343c4f7b9ec0fcae68d9131522)
Diffstat (limited to 'package/kernel/w1-gpio-custom/Makefile')
-rw-r--r--package/kernel/w1-gpio-custom/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/w1-gpio-custom/Makefile b/package/kernel/w1-gpio-custom/Makefile
index 1008cf9736..787f5aa02d 100644
--- a/package/kernel/w1-gpio-custom/Makefile
+++ b/package/kernel/w1-gpio-custom/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=w1-gpio-custom
-PKG_RELEASE:=3
+PKG_RELEASE:=4
include $(INCLUDE_DIR)/package.mk