aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/ubnt-ledbar/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-09-30 11:26:47 +0200
committerFelix Fietkau <nbd@nbd.name>2022-09-30 11:28:51 +0200
commit4363faef8a8c975410f001858b010170942aacfc (patch)
tree6724d328151cc7066044fcb98330cfc40f1da54b /package/kernel/ubnt-ledbar/Makefile
parenta0a4cfd83b9f09c4562c065d0017b389b2987263 (diff)
downloadupstream-4363faef8a8c975410f001858b010170942aacfc.tar.gz
upstream-4363faef8a8c975410f001858b010170942aacfc.tar.bz2
upstream-4363faef8a8c975410f001858b010170942aacfc.zip
kernel: move ubnt ledbar driver to a separate package
Simplifies the tree by removing a non-upstream kernel patch and related kconfig symbols Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/ubnt-ledbar/Makefile')
-rw-r--r--package/kernel/ubnt-ledbar/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/package/kernel/ubnt-ledbar/Makefile b/package/kernel/ubnt-ledbar/Makefile
new file mode 100644
index 0000000000..8fbae9ab94
--- /dev/null
+++ b/package/kernel/ubnt-ledbar/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2008-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=ubnt-ledbar
+PKG_RELEASE:=1
+PKG_LICENSE:=GPL-2.0
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/leds-ubnt-ledbar
+ SUBMENU:=LED modules
+ TITLE:=Ubiquiti UniFi 6 LR LED support
+ FILES:= \
+ $(PKG_BUILD_DIR)/leds-ubnt-ledbar.ko
+ AUTOLOAD:=$(call AutoProbe,leds-ubnt-ledbar,1)
+ DEPENDS:=@TARGET_mediatek_mt7622 +kmod-i2c-core
+endef
+
+define KernelPackage/leds-ubnt-ledbar/description
+ LED support for Ubiquiti UniFi 6 LR
+endef
+
+define Build/Compile
+ $(KERNEL_MAKE) M="$(PKG_BUILD_DIR)" modules
+endef
+
+$(eval $(call KernelPackage,leds-ubnt-ledbar))