aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/qca-ssdk/patches/0013-qca-ssdk-fix-compilation-issue-in-Linux-Style-Makefi.patch
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2023-05-23 14:55:48 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-23 23:52:58 +0200
commit4a6847ce4e4a8034738484a0ff4cb012fa1b295e (patch)
tree92121d70e450de1983bec682e8c1e488f5edb805 /package/kernel/qca-ssdk/patches/0013-qca-ssdk-fix-compilation-issue-in-Linux-Style-Makefi.patch
parent7df43979d102fac7b4f5ca519512c601709aac3b (diff)
downloadupstream-4a6847ce4e4a8034738484a0ff4cb012fa1b295e.tar.gz
upstream-4a6847ce4e4a8034738484a0ff4cb012fa1b295e.tar.bz2
upstream-4a6847ce4e4a8034738484a0ff4cb012fa1b295e.zip
kernel: qca-ssdk: backport support for building as kernel module
Currently, SSDK is rather special in the sense that its not being built as a proper out of tree module at all but rather like a userspace application and that involves a lot of make magic which unfortunately broke with make version 4.4 and newer. Luckily QCA finally added a way to build SSDK as an out of tree module and it uses the kernel buildsystem which makes it compile with make 4.4 as well. So lets backport the support for it and switch to using it. Signed-off-by: Robert Marko <robimarko@gmail.com> (cherry picked from commit 957f1ee85eb243c5c7397b1e3842a3c61a6b852f)
Diffstat (limited to 'package/kernel/qca-ssdk/patches/0013-qca-ssdk-fix-compilation-issue-in-Linux-Style-Makefi.patch')
-rw-r--r--package/kernel/qca-ssdk/patches/0013-qca-ssdk-fix-compilation-issue-in-Linux-Style-Makefi.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/package/kernel/qca-ssdk/patches/0013-qca-ssdk-fix-compilation-issue-in-Linux-Style-Makefi.patch b/package/kernel/qca-ssdk/patches/0013-qca-ssdk-fix-compilation-issue-in-Linux-Style-Makefi.patch
new file mode 100644
index 0000000000..792cd9e31b
--- /dev/null
+++ b/package/kernel/qca-ssdk/patches/0013-qca-ssdk-fix-compilation-issue-in-Linux-Style-Makefi.patch
@@ -0,0 +1,27 @@
+From 3026f89b06049df01d5fe19c5fccc972637aa344 Mon Sep 17 00:00:00 2001
+From: crao <quic_crao@quicinc.com>
+Date: Tue, 7 Mar 2023 17:15:07 +0800
+Subject: [PATCH] [qca-ssdk]: fix compilation issue in Linux-Style Makefile
+
+Change-Id: If38251fc0a2bf4abc666d30f4812c0d9507310dc
+Signed-off-by: crao <quic_crao@quicinc.com>
+---
+ Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+ mode change 100644 => 100755 Makefile
+
+--- a/Makefile
++++ b/Makefile
+@@ -27,9 +27,9 @@ all: $(BIN_DIR) kslib
+ # LNX Modules-Style Makefile
+ ####################################################################
+ modules: $(BIN_DIR) kslib_c
+- cp Makefile.modules ./Makefile;
+- make -C $(SYS_PATH) M=$(PRJ_PATH)/ $(LNX_MAKEOPTS) modules
+- cp *.ko build/bin;
++ mkdir -p ./temp/;cp * ./temp -a;cd ./temp;cp ../Makefile.modules ./Makefile;
++ make -C $(SYS_PATH) M=$(PRJ_PATH)/temp $(LNX_MAKEOPTS) modules
++ cp temp/*.ko build/bin;
+ @echo "---Build [SSDK-$(VERSION)] at $(BUILD_DATE) finished."
+
+ kslib_c: