aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/qca-ssdk/patches/0001-SSDK-config-add-kernel-5.10.patch
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2022-08-20 12:30:50 +0200
committerRobert Marko <robimarko@gmail.com>2023-01-16 12:42:23 +0100
commitc608f7032576296943f6d0914f226ebcfa1cbe4f (patch)
treef0c047d6ab1233d3515c14e8b88accd548bd701e /package/kernel/qca-ssdk/patches/0001-SSDK-config-add-kernel-5.10.patch
parentd092dee9edf2b0703a12258c88d2e3dbc09c9f2a (diff)
downloadupstream-c608f7032576296943f6d0914f226ebcfa1cbe4f.tar.gz
upstream-c608f7032576296943f6d0914f226ebcfa1cbe4f.tar.bz2
upstream-c608f7032576296943f6d0914f226ebcfa1cbe4f.zip
kernel: add Qualcomm SSDK driver
Qualcomm SSDK is driver for Qualcomm Atheros switches and PHY-s. It is quite complicated and used by rest of the Qualcomm SDK stack for anything switch or PHY related. It is required for IPQ807x support as currently, there is no better driver for the built-in switch or UNIPHY. So, lets add the fixed-up version that supports kernel 5.15 for use on ipq807x target until a better driver is available. Signed-off-by: Alexandru Gagniuc <mr.nuke.me@gmail.com> Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package/kernel/qca-ssdk/patches/0001-SSDK-config-add-kernel-5.10.patch')
-rw-r--r--package/kernel/qca-ssdk/patches/0001-SSDK-config-add-kernel-5.10.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/package/kernel/qca-ssdk/patches/0001-SSDK-config-add-kernel-5.10.patch b/package/kernel/qca-ssdk/patches/0001-SSDK-config-add-kernel-5.10.patch
new file mode 100644
index 0000000000..be83d6f1ee
--- /dev/null
+++ b/package/kernel/qca-ssdk/patches/0001-SSDK-config-add-kernel-5.10.patch
@@ -0,0 +1,56 @@
+From 6ee395e1cab32d1d4899d7846ea99e6e2dc0a9e4 Mon Sep 17 00:00:00 2001
+From: Robert Marko <robimarko@gmail.com>
+Date: Wed, 12 May 2021 13:41:12 +0200
+Subject: [PATCH 01/11] SSDK: config: add kernel 5.10
+
+This is purely to identify it and be able to set
+flags correctly.
+
+Signed-off-by: Robert Marko <robimarko@gmail.com>
+---
+ config | 6 +++++-
+ make/linux_opt.mk | 4 ++--
+ 2 files changed, 7 insertions(+), 3 deletions(-)
+
+--- a/config
++++ b/config
+@@ -24,6 +24,10 @@ ifeq ($(KVER),$(filter 5.4%,$(KVER)))
+ OS_VER=5_4
+ endif
+
++ifeq ($(KVER),$(filter 5.10%,$(KVER)))
++OS_VER=5_10
++endif
++
+ ifeq ($(KVER), 3.4.0)
+ OS_VER=3_4
+ endif
+@@ -132,7 +136,7 @@ ifeq ($(ARCH), arm)
+ endif
+
+ ifeq ($(ARCH), arm64)
+- ifeq ($(KVER),$(filter 4.1% 4.4% 4.9% 5.4%,$(KVER)))
++ ifeq ($(KVER),$(filter 4.1% 4.4% 4.9% 5.4% 5.10%,$(KVER)))
+ CPU_CFLAG= -DMODULE -Os -pipe -march=armv8-a -mcpu=cortex-a53+crypto -fno-caller-saves -fno-strict-aliasing -Werror -fno-common -Wno-format-security -Wno-pointer-sign -Wno-unused-but-set-variable -Wno-error=unused-result -mcmodel=large
+ endif
+ endif
+--- a/make/linux_opt.mk
++++ b/make/linux_opt.mk
+@@ -437,7 +437,7 @@ ifeq (KSLIB, $(MODULE_TYPE))
+ KASAN_SHADOW_SCALE_SHIFT := 3
+ endif
+
+- ifeq (5_4, $(OS_VER))
++ ifeq ($(OS_VER),$(filter 5_4 5_10, $(OS_VER)))
+ ifeq ($(ARCH), arm64)
+ KASAN_OPTION += -DKASAN_SHADOW_SCALE_SHIFT=$(KASAN_SHADOW_SCALE_SHIFT)
+ endif
+@@ -468,7 +468,7 @@ ifeq (KSLIB, $(MODULE_TYPE))
+
+ endif
+
+- ifeq ($(OS_VER),$(filter 4_4 5_4, $(OS_VER)))
++ ifeq ($(OS_VER),$(filter 4_4 5_4 5_10, $(OS_VER)))
+ MODULE_CFLAG += -DKVER34
+ MODULE_CFLAG += -DKVER32
+ MODULE_CFLAG += -DLNX26_22