aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mt76
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-05 22:38:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-05 22:38:39 +0000
commit53a0131c686511f8b896cc589d3fda05fa30223e (patch)
tree848157d042ebab6cb2e9e0ec5cf4e5ac04d78ed7 /package/kernel/mt76
parenta42d0f389e9c126420f2a16728a2116a5a27b989 (diff)
downloadupstream-53a0131c686511f8b896cc589d3fda05fa30223e.tar.gz
upstream-53a0131c686511f8b896cc589d3fda05fa30223e.tar.bz2
upstream-53a0131c686511f8b896cc589d3fda05fa30223e.zip
mt76: sync with trunk r47143, add backports for compat with the older mac80211 version
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47145 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mt76')
-rw-r--r--package/kernel/mt76/Makefile4
-rw-r--r--package/kernel/mt76/patches/001-backport_ieee80211_hw_set.patch12
-rw-r--r--package/kernel/mt76/patches/002-disable_fast_xmit.patch10
-rw-r--r--package/kernel/mt76/patches/100-dma-fix-rx-buffer-allocation-size.patch18
4 files changed, 24 insertions, 20 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index bcf69b231d..2a3ddfa31f 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mt76
-PKG_VERSION:=2015-06-15
+PKG_VERSION:=2015-10-05
PKG_RELEASE=1
PKG_LICENSE:=GPLv2
@@ -10,7 +10,7 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=ec91841868a554375b3019bcfaa13ae6d20fe91c
+PKG_SOURCE_VERSION:=0169cab3e4e8377ab5a508895ec893c4e00dbbc5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
diff --git a/package/kernel/mt76/patches/001-backport_ieee80211_hw_set.patch b/package/kernel/mt76/patches/001-backport_ieee80211_hw_set.patch
new file mode 100644
index 0000000000..e94574dc43
--- /dev/null
+++ b/package/kernel/mt76/patches/001-backport_ieee80211_hw_set.patch
@@ -0,0 +1,12 @@
+--- a/init.c
++++ b/init.c
+@@ -16,6 +16,9 @@
+ #include "eeprom.h"
+ #include "mcu.h"
+
++#define ieee80211_hw_set(hw, flag) \
++ do { (hw)->flags |= IEEE80211_HW_##flag; } while(0)
++
+ static bool
+ mt76_wait_for_mac(struct mt76_dev *dev)
+ {
diff --git a/package/kernel/mt76/patches/002-disable_fast_xmit.patch b/package/kernel/mt76/patches/002-disable_fast_xmit.patch
new file mode 100644
index 0000000000..f7a011b2e1
--- /dev/null
+++ b/package/kernel/mt76/patches/002-disable_fast_xmit.patch
@@ -0,0 +1,10 @@
+--- a/init.c
++++ b/init.c
+@@ -816,7 +816,6 @@ int mt76_register_device(struct mt76_dev
+ ieee80211_hw_set(hw, HOST_BROADCAST_PS_BUFFERING);
+ ieee80211_hw_set(hw, AMPDU_AGGREGATION);
+ ieee80211_hw_set(hw, SUPPORTS_RC_TABLE);
+- ieee80211_hw_set(hw, SUPPORT_FAST_XMIT);
+
+ hw->sta_data_size = sizeof(struct mt76_sta);
+ hw->vif_data_size = sizeof(struct mt76_vif);
diff --git a/package/kernel/mt76/patches/100-dma-fix-rx-buffer-allocation-size.patch b/package/kernel/mt76/patches/100-dma-fix-rx-buffer-allocation-size.patch
deleted file mode 100644
index c29c9ba855..0000000000
--- a/package/kernel/mt76/patches/100-dma-fix-rx-buffer-allocation-size.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-From: Felix Fietkau <nbd@openwrt.org>
-Date: Sat, 18 Jul 2015 17:51:24 +0200
-Subject: [PATCH] dma: fix rx buffer allocation size
-
-Signed-off-by: Felix Fietkau <nbd@openwrt.org>
----
-
---- a/dma.c
-+++ b/dma.c
-@@ -158,7 +158,7 @@ mt76_dma_rx_fill(struct mt76_dev *dev, s
- while (q->queued < q->ndesc - 1) {
- int offset = mt76_rx_buf_offset(dev);
-
-- buf = kzalloc(len, GFP_ATOMIC);
-+ buf = kzalloc(q->buf_size, GFP_ATOMIC);
- if (!buf)
- break;
-