aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mt76/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2020-12-18 19:03:55 +0100
committerFelix Fietkau <nbd@nbd.name>2021-02-14 19:55:45 +0100
commitbc3963764d5a3bc2371a890dbe76d3b6dc131d10 (patch)
treee8b09ebd1d4b499b1ff255ec1a891353bb1d2f66 /package/kernel/mt76/Makefile
parent2591c83b3406c16d3c1cd2dc7fa59c3c1b901d3c (diff)
downloadupstream-bc3963764d5a3bc2371a890dbe76d3b6dc131d10.tar.gz
upstream-bc3963764d5a3bc2371a890dbe76d3b6dc131d10.tar.bz2
upstream-bc3963764d5a3bc2371a890dbe76d3b6dc131d10.zip
mt76: update to the latest version
261d184cebdc mt76: introduce mt76_vif data structure 50349a8664ef mt76: mt76_connac: create mcu library c88859180c51 mt76: mt76_connac: move hw_scan and sched_scan routine in mt76_connac_mcu module 9856236ab4f9 mt76: mt76_connac: move WoW and suspend code in mt76_connac_mcu module 2da59aacdd50 mt76: mt76_connac: move pm data struct in mt76_connac.h 16be142e40fe mt76: mt76_connac: move pm utility routines in mt76_connac_lib module c4ccfc66347d mt76: mt7921: add MAC support 8ecf3a50e7ad mt76: mt7921: add MCU support 92c1717f9a55 mt76: mt7921: add DMA support 1cecf9c3da8b mt76: mt7921: add EEPROM support a9e68410b9ba mt76: mt7921: add ieee80211_ops 39d6f4851b06 mt76: mt7921: introduce mt7921e support 9f37baecf5d6 mt76: mt7921: add debugfs support b16cf6e26998 mt76: mt7921: introduce schedule scan support 5aa798ee56c7 mt76: mt7921: introduce 802.11 PS support in sta mode e67d5216f16d mt76: mt7921: introduce support for hardware beacon filter cb99bf4655f9 mt76: mt7921: introduce beacon_loss mcu event 71f9f09ee987 mt76: mt7921: introduce PM support 2beb9c9530d4 mt76: mt7921: rely on mt76_connac_mcu common library 59e682497d12 mt76: mt7921: rely on mt76_connac_mcu module for sched_scan and hw_scan 1ccf6a9c60cd mt76: mt7921: rely on mt76_connac_mcu module for suspend and WoW support f8d1ec5e6e11 mt76: mt7921: introduce Runtime PM support 633a1cbd8f4e mt76: mt7921: introduce regdomain notifier support 0d95c6ad1745 mt76: mt7921: enable MSI interrupts 5f4f6792fb37 mt76: mt7921: add coredump support 47eb00e13450 mt76: mt7663: introduce coredump support 26658849a465 mt76: mt7615: fix key set/delete issues b0ba039bc2ef mt76: mt7615: fix tx skb dma unmap 892f74d37e88 mt76: mt7915: fix tx skb dma unmap 2659f6c6ea23 mt76: mt7615: support loading EEPROM for MT7613BE b09cc8644529 mt76: dma: do not report truncated frames to mac80211 ae6473f1d2af mt76: mt7921: enable random mac addr during scanning b59e3677476d mt76: mt7921: remove unnecessary variable 781911f167aa mt76: mt7921: removed unused definitions in mcu.h 994893d38d51 mt76: always use WTBL_MAX_SIZE for tlv allocation e6c0948ada07 mt76: mt76x0: disable GTK offloading a75302bcbfe1 mt76: connac: always check return value from mt76_connac_mcu_alloc_wtbl_req 8da10d6f9251 mt76: mt7915: always check return value from mt7915_mcu_alloc_wtbl_req 80a87412e9e9 mt76: mt7915: fix uninitialized variable in mt7915_tm_set_tx_cont() c7d98fc35865 mt76: use PCI_VENDOR_ID_MEDIATEK to avoid open coded b5228e75e422 mt76: mt7921: switch to new api for hardware beacon filter 73fce2cbfa41 mt76: connac: fix up the setting for ht40 mode in mt76_connac_mcu_uni_add_bss 2e2cb71901e8 mt76: mt7921: fixup rx bitrate statistics 2d7b1d72b43b mt76: mt7921: add flush operation 96b4c9874e16 mt76: mt7921: fix uninitialized pointer access in mt7921_get_wtbl_info 4492d801cbb5 mt76: connac: update sched_scan cmd usage 200c1b1c234b mac80211: rename csa counters to countdown counters 0d7564d0d899 mt76: add support for 802.3 rx frames 4c0811c647b9 mt76: mt7915: enable hw rx-amsdu de-aggregation 4b7a68634ff6 mt76: mt7915: add rx checksum offload support 289cd7804587 mt76: mt7915: add support for rx decapsulation offload Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/mt76/Makefile')
-rw-r--r--package/kernel/mt76/Makefile32
1 files changed, 28 insertions, 4 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 05d710387c..810ee4c3d4 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2021-01-27
-PKG_SOURCE_VERSION:=8696919d9aae9b673f916bca41c5e1671eec5b0e
-PKG_MIRROR_HASH:=82675e11f537eaa2fe2c1029880f7993ed4401d0d59b12faf6dbe96ac3eb8308
+PKG_SOURCE_DATE:=2021-02-14
+PKG_SOURCE_VERSION:=289cd7804587dc48f776d450db9cd3762692a370
+PKG_MIRROR_HASH:=91885feca9d935586c6e33a8e3734bfa61991d869bf42ac0d1c8c3b19bfa9653
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_BUILD_PARALLEL:=1
@@ -143,11 +143,19 @@ define KernelPackage/mt7603
AUTOLOAD:=$(call AutoProbe,mt7603e)
endef
+define KernelPackage/mt76-connac
+ $(KernelPackage/mt76-default)
+ TITLE:=MediaTek MT7615/MT79xx wireless driver common code
+ HIDDEN:=1
+ DEPENDS+=+kmod-mt76-core
+ FILES:= $(PKG_BUILD_DIR)/mt76-connac-lib.ko
+endef
+
define KernelPackage/mt7615-common
$(KernelPackage/mt76-default)
TITLE:=MediaTek MT7615 wireless driver common code
HIDDEN:=1
- DEPENDS+=@PCI_SUPPORT +kmod-mt76-core
+ DEPENDS+=@PCI_SUPPORT +kmod-mt76-core +kmod-mt76-connac
FILES:= $(PKG_BUILD_DIR)/mt7615/mt7615-common.ko
endef
@@ -210,6 +218,14 @@ define KernelPackage/mt7915e
AUTOLOAD:=$(call AutoProbe,mt7915e)
endef
+define KernelPackage/mt7921e
+ $(KernelPackage/mt76-default)
+ TITLE:=MediaTek MT7921e wireless driver
+ DEPENDS+=@PCI_SUPPORT +kmod-mt76-connac
+ FILES:= $(PKG_BUILD_DIR)/mt7921/mt7921e.ko
+ AUTOLOAD:=$(call AutoProbe,mt7921e)
+endef
+
define Package/mt76-test
SECTION:=devel
CATEGORY:=Development
@@ -267,6 +283,9 @@ endif
ifdef CONFIG_PACKAGE_kmod-mt7603
PKG_MAKE_FLAGS += CONFIG_MT7603E=m
endif
+ifdef CONFIG_PACKAGE_kmod-mt76-connac
+ PKG_MAKE_FLAGS += CONFIG_MT76_CONNAC_LIB=m
+endif
ifdef CONFIG_PACKAGE_kmod-mt7615-common
PKG_MAKE_FLAGS += CONFIG_MT7615_COMMON=m
endif
@@ -290,6 +309,9 @@ endif
ifdef CONFIG_PACKAGE_kmod-mt7915e
PKG_MAKE_FLAGS += CONFIG_MT7915E=m
endif
+ifdef CONFIG_PACKAGE_kmod-mt7921e
+ PKG_MAKE_FLAGS += CONFIG_MT7921E=m
+endif
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \
@@ -400,6 +422,7 @@ $(eval $(call KernelPackage,mt76x2-common))
$(eval $(call KernelPackage,mt76x2u))
$(eval $(call KernelPackage,mt76x2))
$(eval $(call KernelPackage,mt7603))
+$(eval $(call KernelPackage,mt76-connac))
$(eval $(call KernelPackage,mt7615-common))
$(eval $(call KernelPackage,mt7615-firmware))
$(eval $(call KernelPackage,mt7615e))
@@ -409,5 +432,6 @@ $(eval $(call KernelPackage,mt7663-usb-sdio))
$(eval $(call KernelPackage,mt7663u))
$(eval $(call KernelPackage,mt7663s))
$(eval $(call KernelPackage,mt7915e))
+$(eval $(call KernelPackage,mt7921e))
$(eval $(call KernelPackage,mt76))
$(eval $(call BuildPackage,mt76-test))