aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mt76/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-10-19 12:43:03 +0200
committerFelix Fietkau <nbd@nbd.name>2021-10-20 11:35:34 +0200
commit192c41001a46ed2c4545aa82e4271802e3357f04 (patch)
treeb3c0f70126350e1e5815962686a6082854d17d64 /package/kernel/mt76/Makefile
parente62c5504701c7a665c9cf89ddbcb062f5ade6e37 (diff)
downloadupstream-192c41001a46ed2c4545aa82e4271802e3357f04.tar.gz
upstream-192c41001a46ed2c4545aa82e4271802e3357f04.tar.bz2
upstream-192c41001a46ed2c4545aa82e4271802e3357f04.zip
mt76: update to the latest version
ebf5b2336591 mt7615/mt7915: fix hwmon device name 8d12f9ed275d mt76: mt7615: mt7622: fix ibss and meshpoint e7883cdc0b4e mt76: mt7915: improve code readability in mt7915_mcu_sta_bfer_ht 831d5967abb9 wireless: fix spelling of A-MSDU in HE capabilities f09cb04be261 wireless: align some HE capabilities with the spec 0eeba8f2952d wireless: align HE capabilities A-MPDU Length Exponent Extension 655a6c65b8a7 mt76: mt7915: introduce mt7915_mcu_beacon_check_caps() 4440025d0ba9 mt76: mt7915: fix txbf starec TLV issues 87d2fb6fbff5 mt76: mt7915: improve starec readability of txbf 53c6a3cb7f6b mt76: mt7915: fix sta_rec_wtbl tag len f517845e4f28 mt76: mt7915: rework starec TLV tags 1df017bc39a3 mt76: mt7915: fix muar_idx in mt7915_mcu_alloc_sta_req() 6724b0a9a748 mt76: mt7915: set VTA bit in tx descriptor f1f505cbbb30 mt76: mt7915: set muru platform type 8c9d4b38d258 mt76: mt7915: remove dead code in mt7915_get_et_stats d0ccc4297935 mt76: rely on phy pointer in mt76_register_debugfs_fops routine signature 0af0af82bb97 mt76: mt7915: introduce mt76 debugfs sub-dir for ext-phy 10e85d62f213 mt76: mt7915: improve code readability for xmit-queue handler b6051f7713d2 mt76: sdio: export mt76s_alloc_rx_queue and mt76s_alloc_tx routines 9a97c38a309d mt76: mt7921: get rid of unused variable in mt7921_tx_complete_skb c02847c05884 mt76: mt7921: get rid of unused variable in mt7921_mac_tx_free 60dd47a0a62e mt76: mt7915: remove dead code in debugfs code ce74fc020d81 mt76: mt7921: add MU EDCA cmd support c062f6920356 mt76: mt7921: refactor mac.c to be bus independent bfa909c833e8 mt76: mt7921: refactor dma.c to be pcie specific 6556bddf26d2 mt76: mt7921: refactor mcu.c to be bus independent 1c8418207c86 mt76: mt7921: refactor init.c to be bus independent 6cf8248c1a44 mt76: mt7921: add MT7921_COMMON module 77600b0c10ac mt76: connac: move mcu reg access utility routines in mt76_connac_lib module 65362a00d07d mt76: mt7663s: rely on mcu reg access utility 956206bb55c3 mt76: mt7921: make all event parser reusable between mt7921s and mt7921e f0dedcf6aaf0 mt76: mt7921: use physical addr to unify register access 5079d5b0b13c mt76: sdio: move common code in mt76_sdio module 26257594398b mt76: sdio: introduce parse_irq callback e353424f1b07 mt76: sdio: extend sdio module to support CONNAC2 ddab3dd25f94 mt76: connac: extend mcu_get_nic_capability b2d9a1748a41 mt76: mt7921: rely on mcu_get_nic_capability e6ce5d9cbda0 mt76: mt7921: refactor mt7921_mcu_send_message ce3706a65ccd mt76: mt7921: introduce mt7921s support 3143118baf53 mt76: mt7921s: add reset support 645eac64bece mt76: mt76x0: correct VHT MCS 8/9 tx power eeprom offset d54796787cb7 mt76: move mt76_sta_stats in mt76.h 094e085abf5a mt76: move mt76_ethtool_worker_info in mt76 module f80ab6dde63d mt76: mt7915: run mt7915_get_et_stats holding mt76 mutex 4a11cb67dc27 mt76: mt7915: move tx amsdu stats in mib_stats 486da6fa2512 mt76: do not reset MIB counters in get_stats callback d8837b7c8dcd mt76: mt7921: add some more MIB counters 5ffe086fcd1b mt76: mt7921: introduce stats reporting through ethtool 69154ae23f6b mt76: mt7921: add sta stats accounting in mt7921_mac_add_txs_skb 4b65fbc4e203 mt76: mt7921: move tx amsdu stats in mib_stats 35b8025f466b mt76: mt7921: add per-vif counters in ethtool cfbbd861eb12 mt76: mt7915: enable HE UL MU-MIMO a0b94987df80 mt76: mt7915: rework mt7915_mcu_sta_muru_tlv() 5fbb686e9c0c mt76: mt7915: fix missing HE phy cap b649678c18ca mt76: mt7915: change max rx len limit of hw modules Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/mt76/Makefile')
-rw-r--r--package/kernel/mt76/Makefile47
1 files changed, 40 insertions, 7 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 97cb9e8d59..7bd3b5d3d3 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2021-10-12
-PKG_SOURCE_VERSION:=83598c2e872fd8af29976a5f11afe94e620d6f4f
-PKG_MIRROR_HASH:=f179375318c44fb058403aed98056c4df8df7541e4c9d093ec5c22a2eda9475e
+PKG_SOURCE_DATE:=2021-10-20
+PKG_SOURCE_VERSION:=b649678c18cac4b7c85d7d7d86d17e9e4c9b7641
+PKG_MIRROR_HASH:=83bfe5c5e820bc8f2cbe95fa140a232336ac69c86c6df226738e910b3df525ed
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_USE_NINJA:=0
@@ -152,6 +152,14 @@ define KernelPackage/mt76-connac
FILES:= $(PKG_BUILD_DIR)/mt76-connac-lib.ko
endef
+define KernelPackage/mt76-sdio
+ $(KernelPackage/mt76-default)
+ TITLE:=MediaTek MT7615/MT79xx SDIO driver common code
+ HIDDEN:=1
+ DEPENDS+=+kmod-mt76-core +kmod-mmc
+ FILES:= $(PKG_BUILD_DIR)/mt76-sdio.ko
+endef
+
define KernelPackage/mt7615-common
$(KernelPackage/mt76-default)
TITLE:=MediaTek MT7615 wireless driver common code
@@ -196,9 +204,8 @@ endef
define KernelPackage/mt7663s
$(KernelPackage/mt76-default)
TITLE:=MediaTek MT7663s wireless driver
- DEPENDS+=+kmod-mmc +kmod-mt7615-common +kmod-mt7663-usb-sdio
+ DEPENDS+=+kmod-mt76-sdio +kmod-mt7615-common +kmod-mt7663-usb-sdio
FILES:= \
- $(PKG_BUILD_DIR)/mt76-sdio.ko \
$(PKG_BUILD_DIR)/mt7615/mt7663s.ko
AUTOLOAD:=$(call AutoProbe,mt7663s)
endef
@@ -219,10 +226,25 @@ define KernelPackage/mt7915e
AUTOLOAD:=$(call AutoProbe,mt7915e)
endef
+define KernelPackage/mt7921-common
+ TITLE:=MediaTek MT7615 wireless driver common code
+ HIDDEN:=1
+ DEPENDS+=@PCI_SUPPORT +kmod-mt76-core +kmod-mt76-connac
+ FILES:= $(PKG_BUILD_DIR)/mt7921/mt7921-common.ko
+endef
+
+define KernelPackage/mt7921s
+ $(KernelPackage/mt76-default)
+ TITLE:=MediaTek MT7921s wireless driver
+ DEPENDS+=@PCI_SUPPORT +kmod-mt76-connac +kmod-mt76-sdio +kmod-mt7921-common
+ FILES:= $(PKG_BUILD_DIR)/mt7921/mt7921s.ko
+ AUTOLOAD:=$(call AutoProbe,mt7921s)
+endef
+
define KernelPackage/mt7921e
$(KernelPackage/mt76-default)
TITLE:=MediaTek MT7921e wireless driver
- DEPENDS+=@PCI_SUPPORT +kmod-mt76-connac
+ DEPENDS+=@PCI_SUPPORT +kmod-mt76-connac +kmod-mt7921-common
FILES:= $(PKG_BUILD_DIR)/mt7921/mt7921e.ko
AUTOLOAD:=$(call AutoProbe,mt7921e)
endef
@@ -288,6 +310,9 @@ endif
ifdef CONFIG_PACKAGE_kmod-mt76-connac
PKG_MAKE_FLAGS += CONFIG_MT76_CONNAC_LIB=m
endif
+ifdef CONFIG_PACKAGE_kmod-mt76-sdio
+ PKG_MAKE_FLAGS += CONFIG_MT76_SDIO=m
+endif
ifdef CONFIG_PACKAGE_kmod-mt7615-common
PKG_MAKE_FLAGS += CONFIG_MT7615_COMMON=m
endif
@@ -302,7 +327,6 @@ ifdef CONFIG_PACKAGE_kmod-mt7663-usb-sdio
PKG_MAKE_FLAGS += CONFIG_MT7663_USB_SDIO_COMMON=m
endif
ifdef CONFIG_PACKAGE_kmod-mt7663s
- PKG_MAKE_FLAGS += CONFIG_MT76_SDIO=m
PKG_MAKE_FLAGS += CONFIG_MT7663S=m
endif
ifdef CONFIG_PACKAGE_kmod-mt7663u
@@ -311,6 +335,12 @@ endif
ifdef CONFIG_PACKAGE_kmod-mt7915e
PKG_MAKE_FLAGS += CONFIG_MT7915E=m
endif
+ifdef CONFIG_PACKAGE_kmod-mt7921-common
+ PKG_MAKE_FLAGS += CONFIG_MT7921_COMMON=m
+endif
+ifdef CONFIG_PACKAGE_kmod-mt7921s
+ PKG_MAKE_FLAGS += CONFIG_MT7921S=m
+endif
ifdef CONFIG_PACKAGE_kmod-mt7921e
PKG_MAKE_FLAGS += CONFIG_MT7921E=m
endif
@@ -433,6 +463,7 @@ $(eval $(call KernelPackage,mt76x2u))
$(eval $(call KernelPackage,mt76x2))
$(eval $(call KernelPackage,mt7603))
$(eval $(call KernelPackage,mt76-connac))
+$(eval $(call KernelPackage,mt76-sdio))
$(eval $(call KernelPackage,mt7615-common))
$(eval $(call KernelPackage,mt7615-firmware))
$(eval $(call KernelPackage,mt7615e))
@@ -442,6 +473,8 @@ $(eval $(call KernelPackage,mt7663-usb-sdio))
$(eval $(call KernelPackage,mt7663u))
$(eval $(call KernelPackage,mt7663s))
$(eval $(call KernelPackage,mt7915e))
+$(eval $(call KernelPackage,mt7921-common))
+$(eval $(call KernelPackage,mt7921s))
$(eval $(call KernelPackage,mt7921e))
$(eval $(call KernelPackage,mt76))
$(eval $(call BuildPackage,mt76-test))