aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-01-06 15:09:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-01-06 15:09:43 +0000
commitab3ff6e46b8b7ef5436f80cc1804b1f97338dc8e (patch)
tree58b2dee724fbea1f592ab70cc6af76c8282221f6 /package/kernel/modules
parentdf1b8f99d32d1eeabf752c885d5a13fc12bd598c (diff)
downloadupstream-ab3ff6e46b8b7ef5436f80cc1804b1f97338dc8e.tar.gz
upstream-ab3ff6e46b8b7ef5436f80cc1804b1f97338dc8e.tar.bz2
upstream-ab3ff6e46b8b7ef5436f80cc1804b1f97338dc8e.zip
kernel: add a module for the isl1208 rtc
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35022 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules')
-rw-r--r--package/kernel/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 1c8a3dcfef..ddaef8d901 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -539,6 +539,23 @@ endef
$(eval $(call KernelPackage,pwm-gpio))
+define KernelPackage/rtc-isl1208
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Intersil ISL1208 RTC support
+ $(call AddDepends/rtc)
+ DEPENDS+=+kmod-i2c-core
+ KCONFIG:=CONFIG_RTC_DRV_ISL1208
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-isl1208.ko
+ AUTOLOAD:=$(call AutoLoad,60,rtc-isl1208)
+endef
+
+define KernelPackage/rtc-isl1208/description
+ Kernel module for Intersil ISL1208 RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-isl1208))
+
+
define KernelPackage/rtc-marvell
SUBMENU:=$(OTHER_MENU)
TITLE:=Marvell SoC built-in RTC support