aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-04-03 10:00:40 +0000
committerJohn Crispin <blogic@openwrt.org>2013-04-03 10:00:40 +0000
commit69cd56f5712239699a9092aeb9ca5008050ee981 (patch)
treeaede4deba86fa021a678474d936f908c821a4301 /package/kernel/modules
parentb2423179aad52c386aaf451f36155f20ab29afeb (diff)
downloadupstream-69cd56f5712239699a9092aeb9ca5008050ee981.tar.gz
upstream-69cd56f5712239699a9092aeb9ca5008050ee981.tar.bz2
upstream-69cd56f5712239699a9092aeb9ca5008050ee981.zip
[kernel] add lm92 kernel module
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36181 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules')
-rw-r--r--package/kernel/modules/hwmon.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index d549336b3d..bc1f65281d 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -134,6 +134,20 @@ endef
$(eval $(call KernelPackage,hwmon-lm90))
+define KernelPackage/hwmon-lm92
+ TITLE:=LM92 monitoring support
+ KCONFIG:=CONFIG_SENSORS_LM92
+ FILES:=$(LINUX_DIR)/drivers/hwmon/lm92.ko
+ AUTOLOAD:=$(call AutoLoad,60,lm92)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-lm92/description
+ Kernel module for LM92 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm92))
+
define KernelPackage/hwmon-lm95241
TITLE:=LM95241 monitoring support
KCONFIG:=CONFIG_SENSORS_LM95241