aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:54 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:49:54 +0000
commitddba8e58eac6ef2d50525dcc7dce76d4540be496 (patch)
treea8a588da5c8170706dadb91f1748f5912eac5852 /package/kernel/modules
parentcc0a538994fb29c323a52423ec47d95df751cb6c (diff)
downloadupstream-ddba8e58eac6ef2d50525dcc7dce76d4540be496.tar.gz
upstream-ddba8e58eac6ef2d50525dcc7dce76d4540be496.tar.bz2
upstream-ddba8e58eac6ef2d50525dcc7dce76d4540be496.zip
[x86] move i2c modules back to target modules.mk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32850 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules')
-rw-r--r--package/kernel/modules/i2c.mk35
1 files changed, 0 insertions, 35 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index 50501cf4ba..0eb8a07a81 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -101,41 +101,6 @@ endef
$(eval $(call KernelPackage,i2c-gpio))
-I2C_SCX200_MODULES:=\
- CONFIG_SCx200_I2C:drivers/i2c/busses/scx200_i2c
-
-define KernelPackage/i2c-scx200
- $(call i2c_defaults,$(I2C_SCX200_MODULES),59)
- TITLE:=Geode SCx200 I2C using GPIO pins
- DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
- KCONFIG+= \
- CONFIG_SCx200_I2C_SCL=12 \
- CONFIG_SCx200_I2C_SDA=13
-endef
-
-define KernelPackage/i2c-scx200/description
- Kernel module for I2C using GPIO pins on the Geode SCx200 processors.
-endef
-
-$(eval $(call KernelPackage,i2c-scx200))
-
-
-I2C_SCX200_ACB_MODULES:=\
- CONFIG_SCx200_ACB:drivers/i2c/busses/scx200_acb
-
-define KernelPackage/i2c-scx200-acb
- $(call i2c_defaults,$(I2C_SCX200_ACB_MODULES),59)
- TITLE:=Geode SCx200 ACCESS.bus support
- DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-algo-bit
-endef
-
-define KernelPackage/i2c-scx200-acb/description
- Kernel module for I2C using the ACCESS.bus controllers on the Geode SCx200
- and SC1100 processors and the CS5535 and CS5536 Geode companion devices.
-endef
-
-$(eval $(call KernelPackage,i2c-scx200-acb))
-
OF_I2C_MODULES:=\
CONFIG_OF_I2C:drivers/of/of_i2c