aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-17 02:04:38 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-17 02:04:38 +0000
commit13f7fb3995c81f1e2c43c7969beb8cc34515efe3 (patch)
tree72af00ce1b265cac00e13f64356a20708e3a4aff /package/kernel/modules
parent96e0e6c808daf5cc22fbc2fd6247b9611837cbbe (diff)
downloadupstream-13f7fb3995c81f1e2c43c7969beb8cc34515efe3.tar.gz
upstream-13f7fb3995c81f1e2c43c7969beb8cc34515efe3.tar.bz2
upstream-13f7fb3995c81f1e2c43c7969beb8cc34515efe3.zip
disable package that can't build on atheros target (no pci/usb)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8823 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules')
-rw-r--r--package/kernel/modules/other.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 8644d89ce2..9b5bc6d467 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -92,9 +92,11 @@ endef
$(eval $(call KernelPackage,lp))
+# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
define KernelPackage/soundcore
SUBMENU:=$(OTHER_MENU)
TITLE:=Sound support
+ DEPENDS:=@PCI_SUPPORT||USB_SUPPORT @!TARGET_atheros
KCONFIG:= \
CONFIG_SOUND \
CONFIG_SND \
@@ -238,10 +240,11 @@ endef
$(eval $(call KernelPackage,pcmcia-serial))
+# XXX: remove @!TARGET_* later when we have USB support properly detected on all targets
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT
+ DEPENDS:=@USB_SUPPORT @!TARGET_atheros
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \