aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/usb.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2010-03-29 21:02:14 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2010-03-29 21:02:14 +0000
commit23c3cdcd66b0e0dfb7191dec534538bc1acd534b (patch)
treee7f9e4cd7f088c50f57967a3f40a16f79df78528 /package/kernel/modules/usb.mk
parent809ac20df2d4f9340c0ba91d15c79d8c83efadd9 (diff)
downloadupstream-23c3cdcd66b0e0dfb7191dec534538bc1acd534b.tar.gz
upstream-23c3cdcd66b0e0dfb7191dec534538bc1acd534b.tar.bz2
upstream-23c3cdcd66b0e0dfb7191dec534538bc1acd534b.zip
kernel: fix dependencies for x86 target
kmod-hid and kmod-input-core are directly build into the kernel for the x86 target. No package on x86 should depend on it. This fixes #6963 SVN-Revision: 20590
Diffstat (limited to 'package/kernel/modules/usb.mk')
-rw-r--r--package/kernel/modules/usb.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index 322c62398a..c962e340ed 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -777,7 +777,7 @@ $(eval $(call KernelPackage,usb-net-rndis))
define KernelPackage/usb-hid
-$(call KernelPackage/usb/Depends,@LINUX_2_6 +kmod-input-core +kmod-input-evdev +kmod-hid)
+$(call KernelPackage/usb/Depends,@LINUX_2_6 +!TARGET_x86:kmod-input-core +kmod-input-evdev +!TARGET_x86:kmod-hid)
TITLE:=Support for USB Human Input Devices
KCONFIG:=CONFIG_HID_SUPPORT=y CONFIG_USB_HID
FILES:=$(LINUX_DIR)/drivers/$(USBHID_DIR)/usbhid.ko
@@ -793,7 +793,7 @@ $(eval $(call KernelPackage,usb-hid))
define KernelPackage/usb-yealink
-$(call KernelPackage/usb/Depends,@LINUX_2_6 +kmod-input-core +kmod-input-evdev)
+$(call KernelPackage/usb/Depends,@LINUX_2_6 +!TARGET_x86:kmod-input-core +kmod-input-evdev)
TITLE:=USB Yealink VOIP phone
KCONFIG:=CONFIG_USB_YEALINK CONFIG_INPUT_YEALINK CONFIG_INPUT=m CONFIG_INPUT_MISC=y
FILES:=$(LINUX_DIR)/drivers/$(USBINPUT_DIR)/yealink.ko
@@ -808,7 +808,7 @@ $(eval $(call KernelPackage,usb-yealink))
define KernelPackage/usb-cm109
-$(call KernelPackage/usb/Depends,@LINUX_2_6 +kmod-input-core +kmod-input-evdev)
+$(call KernelPackage/usb/Depends,@LINUX_2_6 +!TARGET_x86:kmod-input-core +kmod-input-evdev)
TITLE:=Support for CM109 device
KCONFIG:=CONFIG_USB_CM109 CONFIG_INPUT_CM109 CONFIG_INPUT=m CONFIG_INPUT_MISC=y
FILES:=$(LINUX_DIR)/drivers/$(USBINPUT_DIR)/cm109.ko