aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/usb.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-08-15 14:11:57 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-08-15 14:11:57 +0000
commitb0b017ab661627b4b012e84167960e4cca3f9b2a (patch)
treef9a69354e763a81239fc7df87a41d50aeda38392 /package/kernel/modules/usb.mk
parent48128d482747dd6b46e325f2a403bacaff43b4f7 (diff)
downloadupstream-b0b017ab661627b4b012e84167960e4cca3f9b2a.tar.gz
upstream-b0b017ab661627b4b012e84167960e4cca3f9b2a.tar.bz2
upstream-b0b017ab661627b4b012e84167960e4cca3f9b2a.zip
package/kernel: create package for the RT305x dwc_otg driver
Based on a patch by Layne Edwards <ledwards76@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27998 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/usb.mk')
-rw-r--r--package/kernel/modules/usb.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index 9e98a102fc..9277154663 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -947,3 +947,22 @@ endef
$(eval $(call KernelPackage,usb-phidget))
+define KernelPackage/usb-rt305x-dwc_otg
+ TITLE:=RT305X USB controller driver
+ DEPENDS:=@TARGET_ramips_rt305x
+ KCONFIG:= \
+ CONFIG_DWC_OTG \
+ CONFIG_DWC_OTG_HOST_ONLY=y \
+ CONFIG_DWC_OTG_DEVICE_ONLY=n \
+ CONFIG_DWC_OTG_DEBUG=n
+ FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
+ AUTOLOAD:=$(call AutoLoad,54,dwc_otg)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-rt305x-dwc_otg/description
+ This driver provides USB Device Controller support for the
+ Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
+endef
+
+$(eval $(call KernelPackage,usb-rt305x-dwc_otg))