aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/usb.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2009-03-07 17:07:24 +0000
committerHauke Mehrtens <hauke@openwrt.org>2009-03-07 17:07:24 +0000
commit2f99a90a3055e7379302430c8992c58e7b814ed8 (patch)
tree14946408e7fb60291d678cc124c841b234fa7c20 /package/kernel/modules/usb.mk
parent3724a89fd62c55075852302b96905c779bd73794 (diff)
downloadupstream-2f99a90a3055e7379302430c8992c58e7b814ed8.tar.gz
upstream-2f99a90a3055e7379302430c8992c58e7b814ed8.tar.bz2
upstream-2f99a90a3055e7379302430c8992c58e7b814ed8.zip
[kernel] extract the rfkill module to an extra package, only build rfkill module if it is not integrated into the kernel.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14780 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/usb.mk')
-rw-r--r--package/kernel/modules/usb.mk10
1 files changed, 3 insertions, 7 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index 66a5a951f3..b6cb96fd32 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -576,16 +576,12 @@ $(eval $(call KernelPackage,usb-net-asix))
define KernelPackage/usb-net-hso
- $(call usbdep,kmod-usb-net @LINUX_2_6 @!LINUX_2_6_21 @!LINUX_2_6_23 @!LINUX_2_6_24 @!LINUX_2_6_25)
+ $(call usbdep,kmod-usb-net @LINUX_2_6 @!LINUX_2_6_21 @!LINUX_2_6_23 @!LINUX_2_6_24 @!LINUX_2_6_25 +!TARGET_rb532||!TARGET_avr32||!TARGET_brcm47xx||!TARGET_s3c24xx||!TARGET_ifxmips||!TARGET_atheros||!TARGET_adm5120||!TARGET_ar7||!TARGET_ppc40x||!TARGET_ixp4xx||!TARGET_rdc:kmod-rfkill)
TITLE:=Kernel module for Option USB High Speed Mobile Devices
- KCONFIG:= \
- CONFIG_RFKILL \
- CONFIG_RFKILL_INPUT \
- CONFIG_USB_HSO
+ KCONFIG:=CONFIG_USB_HSO
FILES:= \
- $(LINUX_DIR)/net/rfkill/rfkill.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/drivers/$(USBNET_DIR)/hso.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,61,rfkill hso)
+ AUTOLOAD:=$(call AutoLoad,61,hso)
endef
define KernelPackage/usb-net-hso/description