aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/sound.mk
diff options
context:
space:
mode:
authorVasilis Tsiligiannis <b_tsiligiannis@silverton.gr>2011-05-15 09:37:28 +0000
committerVasilis Tsiligiannis <b_tsiligiannis@silverton.gr>2011-05-15 09:37:28 +0000
commitc5258d54b25a197e4ce5a73552afa427046bc8c3 (patch)
tree0bd8f9c655e689944810334e0d329d73d738fd99 /package/kernel/modules/sound.mk
parent7d202aa4314a9cd0a565f24df559291fa4adc7cb (diff)
downloadupstream-c5258d54b25a197e4ce5a73552afa427046bc8c3.tar.gz
upstream-c5258d54b25a197e4ce5a73552afa427046bc8c3.tar.bz2
upstream-c5258d54b25a197e4ce5a73552afa427046bc8c3.zip
package/kernel: Remove all 2.4 definitions
With no 2.4 support in trunk, we can safely remove any 2.4 definitions for kmods and merge the 2.6 definitions into the generic ones. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26901 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/sound.mk')
-rw-r--r--package/kernel/modules/sound.mk50
1 files changed, 21 insertions, 29 deletions
diff --git a/package/kernel/modules/sound.mk b/package/kernel/modules/sound.mk
index b46f25128a..2d0a987b64 100644
--- a/package/kernel/modules/sound.mk
+++ b/package/kernel/modules/sound.mk
@@ -22,34 +22,7 @@ endef
$(eval $(call KernelPackage,pcspkr))
-define KernelPackage/sound-core
- SUBMENU:=$(SOUND_MENU)
- TITLE:=Sound support
- DEPENDS:=@AUDIO_SUPPORT
- KCONFIG:= \
- CONFIG_SOUND \
- CONFIG_SND \
- CONFIG_SND_HWDEP \
- CONFIG_SND_RAWMIDI \
- CONFIG_SND_TIMER \
- CONFIG_SND_PCM \
- CONFIG_SND_SEQUENCER \
- CONFIG_SND_VIRMIDI \
- CONFIG_SND_SEQ_DUMMY \
- CONFIG_SND_SEQUENCER_OSS=y \
- CONFIG_HOSTAUDIO \
- CONFIG_SND_PCM_OSS \
- CONFIG_SND_MIXER_OSS \
- CONFIG_SOUND_OSS_CORE_PRECLAIM=y
- $(call AddDepends/input)
-endef
-
-define KernelPackage/sound-core/2.4
- FILES:=$(LINUX_DIR)/drivers/sound/soundcore.ko
- AUTOLOAD:=$(call AutoLoad,30,soundcore)
-endef
-
-# allow 2.6 targets to override the soundcore stuff
+# allow targets to override the soundcore stuff
SOUNDCORE_LOAD ?= \
soundcore \
snd \
@@ -74,9 +47,28 @@ SOUNDCORE_FILES ?= \
$(LINUX_DIR)/sound/core/oss/snd-mixer-oss.ko \
$(LINUX_DIR)/sound/core/oss/snd-pcm-oss.ko
-define KernelPackage/sound-core/2.6
+define KernelPackage/sound-core
+ SUBMENU:=$(SOUND_MENU)
+ TITLE:=Sound support
+ DEPENDS:=@AUDIO_SUPPORT
+ KCONFIG:= \
+ CONFIG_SOUND \
+ CONFIG_SND \
+ CONFIG_SND_HWDEP \
+ CONFIG_SND_RAWMIDI \
+ CONFIG_SND_TIMER \
+ CONFIG_SND_PCM \
+ CONFIG_SND_SEQUENCER \
+ CONFIG_SND_VIRMIDI \
+ CONFIG_SND_SEQ_DUMMY \
+ CONFIG_SND_SEQUENCER_OSS=y \
+ CONFIG_HOSTAUDIO \
+ CONFIG_SND_PCM_OSS \
+ CONFIG_SND_MIXER_OSS \
+ CONFIG_SOUND_OSS_CORE_PRECLAIM=y
FILES:=$(SOUNDCORE_FILES)
AUTOLOAD:=$(call AutoLoad,30,$(SOUNDCORE_LOAD))
+ $(call AddDepends/input)
endef
define KernelPackage/sound-core/uml