aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/sound.mk
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-02-06 11:49:22 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-02-06 11:49:22 +0000
commit4a753f738c85a4211ea65b5c16206ff4badbc0c7 (patch)
tree8f22df87b49e89133973d43bc4babc54f7cf7c32 /package/kernel/modules/sound.mk
parent0d9096a2d60e47491e755476ec9426c9a10fe375 (diff)
downloadupstream-4a753f738c85a4211ea65b5c16206ff4badbc0c7.tar.gz
upstream-4a753f738c85a4211ea65b5c16206ff4badbc0c7.tar.bz2
upstream-4a753f738c85a4211ea65b5c16206ff4badbc0c7.zip
Added PS3 sound driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14422 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/sound.mk')
-rw-r--r--package/kernel/modules/sound.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/sound.mk b/package/kernel/modules/sound.mk
index 1aa0bf317a..1b9b81a72a 100644
--- a/package/kernel/modules/sound.mk
+++ b/package/kernel/modules/sound.mk
@@ -91,6 +91,22 @@ endef
$(eval $(call KernelPackage,sound-i8x0))
+define KernelPackage/sound-ps3
+ SUBMENU:=$(SOUND_MENU)
+ TITLE:=PS3 Audio
+ DEPENDS:=kmod-sound-core
+ KCONFIG:=CONFIG_SND_PS3 \
+ CONFIG_SND_PPC
+ FILES:=$(LINUX_DIR)/sound/ppc/snd_ps3.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,35, snd_ps3)
+endef
+
+define KernelPackage/sound-ps3/description
+ support for the integrated PS3 audio device
+endef
+
+$(eval $(call KernelPackage,sound-ps3))
+
define KernelPackage/sound-cs5535audio
SUBMENU:=$(SOUND_MENU)
TITLE:=CS5535 PCI Controller