aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-05-17 15:28:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-05-17 15:28:13 +0000
commitce9b21bc113074b2343b75ec4a554216eae3e3c6 (patch)
tree69910db55a2b1781cd0c5fb4876688d463ebf4e2 /package/kernel/modules/other.mk
parent03babf3641a0436732c8b733b943fa33abbbe62a (diff)
downloadupstream-ce9b21bc113074b2343b75ec4a554216eae3e3c6.tar.gz
upstream-ce9b21bc113074b2343b75ec4a554216eae3e3c6.tar.bz2
upstream-ce9b21bc113074b2343b75ec4a554216eae3e3c6.zip
kernel: remove the dummy kmod-rtc-core-* package, make all rtc drivers depend on @RTC_SUPPORT - prevent RTC support from leaking into kernels for targets that do not need this
SVN-Revision: 31778
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk28
1 files changed, 0 insertions, 28 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 3cf132352e..ea0e91ffee 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -736,34 +736,6 @@ endef
$(eval $(call KernelPackage,pwm-gpio))
-define KernelPackage/rtc-core-2.6
- SUBMENU:=$(OTHER_MENU)
- DEPENDS:=@(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
- TITLE:=Real Time Clock class support
- KCONFIG:=CONFIG_RTC_CLASS
- FILES:=$(LINUX_DIR)/drivers/rtc/rtc-core.ko
- AUTOLOAD:=$(call AutoLoad,29,rtc-core)
-endef
-
-define KernelPackage/rtc-core-2.6/description
- Generic RTC class support.
-endef
-
-$(eval $(call KernelPackage,rtc-core-2.6))
-
-define KernelPackage/rtc-core-3.x
- SUBMENU:=$(OTHER_MENU)
- DEPENDS:=@!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
- TITLE:=Real Time Clock class support
- KCONFIG:=CONFIG_RTC_CLASS=y
-endef
-
-define KernelPackage/rtc-core-3.x/description
- Generic RTC class support.
-endef
-
-$(eval $(call KernelPackage,rtc-core-3.x))
-
define KernelPackage/rtc-pcf8563
SUBMENU:=$(OTHER_MENU)
TITLE:=Philips PCF8563/Epson RTC8564 RTC support