aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-08 22:20:21 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-08 22:20:21 +0000
commit85fbe13cf55745dc63553fa9cc06590521df42d3 (patch)
treefd08083727845a5fd5c8ecd460f66b9a54bec14b /package/kernel/modules/other.mk
parent25475a095ec71f55826a5864e78e09c27031f179 (diff)
downloadupstream-85fbe13cf55745dc63553fa9cc06590521df42d3.tar.gz
upstream-85fbe13cf55745dc63553fa9cc06590521df42d3.tar.bz2
upstream-85fbe13cf55745dc63553fa9cc06590521df42d3.zip
kernel: adjust orion/kirkwood packages to also build for mvebu target
Armada XP/370 boards share these hardware blocks with Orion and Kirkwood SoCs. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 35059
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 5d3e00a87f..d4983a3243 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -479,14 +479,14 @@ $(eval $(call KernelPackage,wdt-omap))
define KernelPackage/wdt-orion
SUBMENU:=$(OTHER_MENU)
TITLE:=Marvell Orion Watchdog timer
- DEPENDS:=@TARGET_orion||@TARGET_kirkwood
+ DEPENDS:=@TARGET_orion||TARGET_kirkwood||TARGET_mvebu
KCONFIG:=CONFIG_ORION_WATCHDOG
FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
AUTOLOAD:=$(call AutoLoad,50,orion_wdt)
endef
define KernelPackage/wdt-orion/description
- Kernel module for Marvell orion watchdog timer.
+ Kernel module for Marvell Orion, Kirkwood and Armada XP/370 watchdog timer.
endef
$(eval $(call KernelPackage,wdt-orion))