aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-05-11 20:56:51 +0000
committerNicolas Thill <nico@openwrt.org>2008-05-11 20:56:51 +0000
commit2f18c70fb64b794976253267fd3dd6c693ae7799 (patch)
treee6a114118dd9c4198851a6b807c42cc48be322a7 /package/kernel/modules/other.mk
parent78aa6df4e3952a1d5ca649a4e248bc4e7db30ce2 (diff)
downloadupstream-2f18c70fb64b794976253267fd3dd6c693ae7799.tar.gz
upstream-2f18c70fb64b794976253267fd3dd6c693ae7799.tar.bz2
upstream-2f18c70fb64b794976253267fd3dd6c693ae7799.zip
add a macro to compare kernel patch versions and use it for crypto and watchdog changes in 2.6.24+ kernels (closes: #3402)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11115 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index bf674644d4..482c06c4a8 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -270,7 +270,7 @@ $(eval $(call KernelPackage,mmc-at91))
ifeq ($(KERNEL),2.4)
WATCHDOG_DIR=char
endif
-ifeq ($(KERNEL_PATCHVER),2.6.24)
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.24)),1)
WATCHDOG_DIR=watchdog
endif
WATCHDOG_DIR?=char/watchdog