aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2009-09-26 21:23:53 +0000
committerHauke Mehrtens <hauke@openwrt.org>2009-09-26 21:23:53 +0000
commitf8688b5d9016c8b0dfe20ae9af3a1f3f70983b04 (patch)
treeae65eb0cfd084ca35fccc38b9da0397d6ffbcf53 /package/kernel/modules/other.mk
parentbedbad16bcca1d5b05bba71f146cd3582e05cf0e (diff)
downloadupstream-f8688b5d9016c8b0dfe20ae9af3a1f3f70983b04.tar.gz
upstream-f8688b5d9016c8b0dfe20ae9af3a1f3f70983b04.tar.bz2
upstream-f8688b5d9016c8b0dfe20ae9af3a1f3f70983b04.zip
small fixes mostly for kernel 2.6.31
- libsas needs symbols from scsi_transport_sas - autoload line in pppoe was missing - rfkill-input does not exist in kernel 2.6.31 - password for download server of r8101 changed - r8101 and siit do not build with kernel 2.6.31 - fix build of net sched esfq git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17752 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 3844068b79..1b8e533cdc 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -784,10 +784,16 @@ define KernelPackage/rfkill
CONFIG_RFKILL \
CONFIG_RFKILL_INPUT \
CONFIG_RFKILL_LEDS=y
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.31)),1)
+ FILES:= \
+ $(LINUX_DIR)/net/rfkill/rfkill.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,20,rfkill)
+else
FILES:= \
$(LINUX_DIR)/net/rfkill/rfkill.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/net/rfkill/rfkill-input.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,20,rfkill rfkill-input)
+endif
endef
define KernelPackage/rfkill/description