aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-05-17 15:28:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-05-17 15:28:02 +0000
commitd25930c39b9ff03e2cfffc0a2dcb64555ebc4c26 (patch)
tree8daf0ef20c41f247c70310beaecf33e6026325ca /package/kernel/modules/other.mk
parent06370f57c10b2d547584fcacaed4abc02c392704 (diff)
downloadupstream-d25930c39b9ff03e2cfffc0a2dcb64555ebc4c26.tar.gz
upstream-d25930c39b9ff03e2cfffc0a2dcb64555ebc4c26.tar.bz2
upstream-d25930c39b9ff03e2cfffc0a2dcb64555ebc4c26.zip
kernel: remove obsolete CompareKernelPatchVer calls
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31775 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk13
1 files changed, 1 insertions, 12 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 1f61da831a..9e4559a9bb 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -44,14 +44,7 @@ define KernelPackage/bluetooth
$(LINUX_DIR)/net/bluetooth/hidp/hidp.ko \
$(LINUX_DIR)/drivers/bluetooth/hci_uart.ko \
$(LINUX_DIR)/drivers/bluetooth/btusb.ko
- ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.39)),1)
- AUTOLOAD:=$(call AutoLoad,90,bluetooth rfcomm bnep hidp hci_uart btusb)
- else
- FILES+= \
- $(LINUX_DIR)/net/bluetooth/l2cap.ko \
- $(LINUX_DIR)/net/bluetooth/sco.ko
- AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hidp hci_uart btusb)
- endif
+ AUTOLOAD:=$(call AutoLoad,90,bluetooth rfcomm bnep hidp hci_uart btusb)
endef
define KernelPackage/bluetooth/description
@@ -922,11 +915,7 @@ define KernelPackage/serial-8250
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250.ko
else
- ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
FILES:=$(LINUX_DIR)/drivers/tty/serial/8250.ko
- else
- FILES:=$(LINUX_DIR)/drivers/serial/8250.ko
- endif
endif
endef