aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-09-04 18:06:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-09-04 18:06:49 +0000
commitbd7ef0f4f19cd96459b870a7251b648b4a056b86 (patch)
tree946d205b2ae838903a3e25ae5b321731bd143cc2 /package/kernel/modules/other.mk
parenta475a611a3db6aa3ff16567d3da64495516abd83 (diff)
downloadupstream-bd7ef0f4f19cd96459b870a7251b648b4a056b86.tar.gz
upstream-bd7ef0f4f19cd96459b870a7251b648b4a056b86.tar.bz2
upstream-bd7ef0f4f19cd96459b870a7251b648b4a056b86.zip
[package] kmod-sctp: Add SCTP kernel support
This adds a new kmod-sctp option that enables support of SCTP in 2.6x kernels. The patch also contains a small cleanup in the dependencies. Signed-off-by: Sebastien Decugis <sdecugis@nict.go.jp> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22917 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 18cd79faf9..53080f8cdf 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -132,6 +132,22 @@ endef
$(eval $(call KernelPackage,crc16))
+define KernelPackage/libcrc32c
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=CRC32 library support
+ KCONFIG:=CONFIG_LIBCRC32C
+ DEPENDS:=+kmod-crypto-core +kmod-crypto-misc
+ FILES:=$(LINUX_DIR)/lib/libcrc32c.ko
+ AUTOLOAD:=$(call AutoLoad,20,crc32c libcrc32c,1)
+endef
+
+define KernelPackage/libcrc32c/description
+ Kernel module for CRC32 support
+endef
+
+$(eval $(call KernelPackage,libcrc32c))
+
+
define KernelPackage/eeprom-93cx6
SUBMENU:=$(OTHER_MENU)
TITLE:=EEPROM 93CX6 support