aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-05-17 15:28:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-05-17 15:28:17 +0000
commit95757184a0b76adafb500cc62fd7ba6e3c8195de (patch)
treec64b663cbff1d6778483195dd36bf98fcba0d5a4 /package/kernel/modules/other.mk
parentbf2796c5993c9539f5d91c53469142c4a58c21ca (diff)
downloadupstream-95757184a0b76adafb500cc62fd7ba6e3c8195de.tar.gz
upstream-95757184a0b76adafb500cc62fd7ba6e3c8195de.tar.bz2
upstream-95757184a0b76adafb500cc62fd7ba6e3c8195de.zip
kernel: remove obsolete dependencies and conditionals
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31779 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index ea0e91ffee..be762533f6 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -825,7 +825,7 @@ $(eval $(call KernelPackage,mtdtests))
define KernelPackage/nand
SUBMENU:=$(OTHER_MENU)
TITLE:=NAND flash support
- DEPENDS:=@!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
+ DEPENDS:=@!LINUX_2_6_39
KCONFIG:=CONFIG_MTD_NAND \
CONFIG_MTD_NAND_IDS \
CONFIG_MTD_NAND_ECC
@@ -846,7 +846,7 @@ $(eval $(call KernelPackage,nand))
define KernelPackage/nandsim
SUBMENU:=$(OTHER_MENU)
TITLE:=NAND simulator
- DEPENDS:=@!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39) +kmod-nand
+ DEPENDS:=+kmod-nand
KCONFIG:=CONFIG_MTD_NAND_NANDSIM
FILES:=$(LINUX_DIR)/drivers/mtd/nand/nandsim.ko
endef