aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-20 10:27:38 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-20 10:27:38 +0000
commit28a4cca917354bd37190cdd8b083a5273b071ec5 (patch)
tree2755b94674ec8aae5bd6e901c7ef459eb93afff7 /package/kernel/modules/other.mk
parent3842e188da35c319e481dc9fad85d4e3fa7cea53 (diff)
downloadupstream-28a4cca917354bd37190cdd8b083a5273b071ec5.tar.gz
upstream-28a4cca917354bd37190cdd8b083a5273b071ec5.tar.bz2
upstream-28a4cca917354bd37190cdd8b083a5273b071ec5.zip
move kernel sound support in its own file from other.mk to sound.mk, rename kmod-soundcore to kmod-sound-core to be consistent, cleanup alsa-lib
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8865 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk66
1 files changed, 0 insertions, 66 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 171c9ce711..c13675739f 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -92,72 +92,6 @@ endef
$(eval $(call KernelPackage,lp))
-# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
-define KernelPackage/soundcore
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Sound support
- DEPENDS:=@USB_SUPPORT @!TARGET_atheros
- KCONFIG:= \
- CONFIG_SOUND \
- CONFIG_SND \
- CONFIG_SND_HWDEP \
- CONFIG_SND_RAWMIDI \
- CONFIG_SND_TIMER \
- CONFIG_SND_PCM \
- CONFIG_HOSTAUDIO
-endef
-
-define KernelPackage/soundcore/2.4
- FILES:=$(LINUX_DIR)/drivers/sound/soundcore.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,30,soundcore)
-endef
-
-define KernelPackage/soundcore/2.6
-# KCONFIG+= \
-# CONFIG_SND \
-# CONFIG_SND_HWDEP \
-# CONFIG_SND_RAWMIDI \
-# CONFIG_SND_TIMER \
-# CONFIG_SND_PCM
- FILES:= \
- $(LINUX_DIR)/sound/soundcore.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/sound/core/snd.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/sound/core/snd-page-alloc.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/sound/core/snd-hwdep.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/sound/core/snd-rawmidi.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/sound/core/snd-timer.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/sound/core/snd-pcm.$(LINUX_KMOD_SUFFIX) \
- $(if $(CONFIG_SND_MIXER_OSS),$(LINUX_DIR)/sound/core/oss/snd-mixer-oss.$(LINUX_KMOD_SUFFIX)) \
- $(if $(CONFIG_SND_PCM_OSS),$(LINUX_DIR)/sound/core/oss/snd-pcm-oss.$(LINUX_KMOD_SUFFIX))
- AUTOLOAD:=$(call AutoLoad,30, \
- soundcore \
- snd \
- snd-page-alloc \
- snd-hwdep \
- snd-rawmidi \
- snd-timer \
- snd-pcm \
- $(if $(CONFIG_SND_MIXER_OSS),snd-mixer-oss) \
- $(if $(CONFIG_SND_PCM_OSS),snd-pcm-oss) \
- )
-endef
-
-define KernelPackage/soundcore/uml-2.6
-# KCONFIG+= \
-# CONFIG_HOSTAUDIO
- FILES:= \
- $(LINUX_DIR)/sound/soundcore.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/arch/um/drivers/hostaudio.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,30,soundcore hostaudio)
-endef
-
-define KernelPackage/soundcore/description
- Kernel modules for sound support
-endef
-
-$(eval $(call KernelPackage,soundcore))
-
-
define KernelPackage/pcmcia-core
SUBMENU:=$(OTHER_MENU)
TITLE:=PCMCIA/CardBus support