aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/netsupport.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-02-14 19:07:13 +0000
committerJohn Crispin <blogic@openwrt.org>2012-02-14 19:07:13 +0000
commit03a8872df7bb6931cacf90a9867590e6f61abc81 (patch)
tree115e963e39e5e9be38c2f12fab7357f0fa904d13 /package/kernel/modules/netsupport.mk
parentf2983914cba71f5021c5ea0a1a5119d989b7943f (diff)
downloadupstream-03a8872df7bb6931cacf90a9867590e6f61abc81.tar.gz
upstream-03a8872df7bb6931cacf90a9867590e6f61abc81.tar.bz2
upstream-03a8872df7bb6931cacf90a9867590e6f61abc81.zip
Add kernel module package for SLIP
This patch adds support for a kernel module package for SLIP. We needed it forusing tunslip6 from Contiki OS for 6LoWPAN communications. Signed-off-by: Markus Becker <mab@comnets.uni-bremen.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30538 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/netsupport.mk')
-rw-r--r--package/kernel/modules/netsupport.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 93607302a2..bac681b75c 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -829,3 +829,28 @@ endef
$(eval $(call KernelPackage,netem))
+define KernelPackage/slip
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=SLIP modules
+ KCONFIG:= \
+ CONFIG_SLIP \
+ CONFIG_SLIP_COMPRESSED=y \
+ CONFIG_SLIP_SMART=y \
+ CONFIG_SLIP_MODE_SLIP6=y
+
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.2)),1)
+ FILES:= \
+ $(LINUX_DIR)/drivers/net/slip/slip.ko
+ else
+ FILES:= \
+ $(LINUX_DIR)/drivers/net/slip.ko
+ endif
+ AUTOLOAD:=$(call AutoLoad,30,slip)
+endef
+
+define KernelPackage/slip/description
+ Kernel modules for SLIP support
+endef
+
+$(eval $(call KernelPackage,slip))
+