aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/netfilter.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-02-02 15:48:52 +0000
committerNicolas Thill <nico@openwrt.org>2009-02-02 15:48:52 +0000
commit9c6d3972ae0ceb267b6771d57cf0025c8cbd506a (patch)
treef55ca0490ab283ae2d5fa038d5bc1a4b6d412822 /package/kernel/modules/netfilter.mk
parent4802edaa2eab2462d0ad869a6b2a2c2030121bc5 (diff)
downloadupstream-9c6d3972ae0ceb267b6771d57cf0025c8cbd506a.tar.gz
upstream-9c6d3972ae0ceb267b6771d57cf0025c8cbd506a.tar.bz2
upstream-9c6d3972ae0ceb267b6771d57cf0025c8cbd506a.zip
[package] kernel: mark modules that won't build on 2.6.28 as broken
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14356 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/netfilter.mk')
-rw-r--r--package/kernel/modules/netfilter.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/modules/netfilter.mk b/package/kernel/modules/netfilter.mk
index 0d86adffc3..c17c8a8def 100644
--- a/package/kernel/modules/netfilter.mk
+++ b/package/kernel/modules/netfilter.mk
@@ -328,13 +328,14 @@ endef
$(eval $(call KernelPackage,ipt-ipset))
+# XXX: broken on 2.6.28 to xt_CHAOS module
define KernelPackage/ipt-extra
SUBMENU:=$(NF_MENU)
TITLE:=Extra modules
KCONFIG:=$(KCONFIG_IPT_EXTRA)
FILES:=$(foreach mod,$(IPT_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_EXTRA-m)))
- DEPENDS:= kmod-ipt-core
+ DEPENDS:= kmod-ipt-core @LINUX_2_6_28:BROKEN
endef
define KernelPackage/ipt-extra/description