aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/netfilter.mk
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-07-17 08:50:19 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-07-17 08:50:19 +0000
commit4ecd145ce0aadf80e9d2fadbd4778fcfae4f2c03 (patch)
tree5726e8ab5ec631dcbb0d3d4b7af5ea3909b87a76 /package/kernel/modules/netfilter.mk
parentb684d2ef23c47a330ef40fbedca979bc2570a840 (diff)
downloadupstream-4ecd145ce0aadf80e9d2fadbd4778fcfae4f2c03.tar.gz
upstream-4ecd145ce0aadf80e9d2fadbd4778fcfae4f2c03.tar.bz2
upstream-4ecd145ce0aadf80e9d2fadbd4778fcfae4f2c03.zip
finalize r22241 fixes
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22242 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/netfilter.mk')
-rw-r--r--package/kernel/modules/netfilter.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/modules/netfilter.mk b/package/kernel/modules/netfilter.mk
index 3ce557aa5b..84f746f9c5 100644
--- a/package/kernel/modules/netfilter.mk
+++ b/package/kernel/modules/netfilter.mk
@@ -514,11 +514,12 @@ endef
$(eval $(call KernelPackage,nf-conntrack-netlink))
define KernelPackage/ipt-hashlimit
-$(call KernelPackage/ipt/Depends,)
+ SUBMENU:=$(NF_MENU)
TITLE:=Netfilter hashlimit match
- FILES:=$(LINUX_DIR)/net/netfilter/xt_hashlimit.ko
KCONFIG:=$(KCONFIG_IPT_HASHLIMIT)
+ FILES:=$(LINUX_DIR)/net/netfilter/xt_hashlimit.ko
AUTOLOAD:=$(call AutoLoad,50,xt_hashlimit)
+ $(call KernelPackage/ipt)
endef
define KernelPackage/ipt-hashlimit/description