aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/hwmon.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-18 19:49:17 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-18 19:49:17 +0000
commita57ceb91f7afdbbac0bbc9d4aa50b0413a41ab38 (patch)
treecab7f9774dbdc8b9002f2624bc40f58d45ff8b93 /package/kernel/modules/hwmon.mk
parentffe645738efe9d1cf356a32cf866ab259a2c5a66 (diff)
downloadupstream-a57ceb91f7afdbbac0bbc9d4aa50b0413a41ab38.tar.gz
upstream-a57ceb91f7afdbbac0bbc9d4aa50b0413a41ab38.tar.bz2
upstream-a57ceb91f7afdbbac0bbc9d4aa50b0413a41ab38.zip
This patch adds a kmod in hwmon for the SHT21 sensor (I2C temperature and humidity sensor)
Signed-off-by: Christian Gagneraud <chris@techworks.ie> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30986 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/hwmon.mk')
-rw-r--r--package/kernel/modules/hwmon.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index 57dd5684cb..61b5b3d602 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -103,6 +103,19 @@ endef
$(eval $(call KernelPackage,hwmon-lm95241))
+define KernelPackage/hwmon-sht21
+ TITLE:=Sensiron SHT21 and compat. monitoring support
+ KCONFIG:=CONFIG_SENSORS_SHT21
+ FILES:=$(LINUX_DIR)/drivers/hwmon/sht21.ko
+ AUTOLOAD:=$(call AutoLoad,60,sht21)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-sht21/description
+ Kernel module for Sensirion SHT21 and SHT25 temperature and humidity sensors chip
+endef
+
+$(eval $(call KernelPackage,hwmon-sht21))
define KernelPackage/hwmon-pc87360
TITLE:=PC87360 monitoring support