aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/hwmon.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-09 10:48:34 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-09 10:48:34 +0000
commit738d6011173afcffe795fb7fb4fdec3cc067963f (patch)
tree61eb153c2ddbe0e66e797c911b389460e4d9a8ac /package/kernel/modules/hwmon.mk
parent3ceade616bc430ced2cf3669da3a0544cf16a786 (diff)
downloadupstream-738d6011173afcffe795fb7fb4fdec3cc067963f.tar.gz
upstream-738d6011173afcffe795fb7fb4fdec3cc067963f.tar.bz2
upstream-738d6011173afcffe795fb7fb4fdec3cc067963f.zip
package/kernel: add package for the LM85 sensor
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31656 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/hwmon.mk')
-rw-r--r--package/kernel/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index 62eceb913f..94f21a67e4 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -90,6 +90,21 @@ endef
$(eval $(call KernelPackage,hwmon-lm77))
+define KernelPackage/hwmon-lm85
+ TITLE:=LM85 monitoring support
+ KCONFIG:=CONFIG_SENSORS_LM85
+ FILES:=$(LINUX_DIR)/drivers/hwmon/lm85.ko
+ AUTOLOAD:=$(call AutoLoad,60,lm85)
+ $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid)
+endef
+
+define KernelPackage/hwmon-lm85/description
+ Kernel module for LM85 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm85))
+
+
define KernelPackage/hwmon-lm90
TITLE:=LM90 monitoring support
KCONFIG:=CONFIG_SENSORS_LM90