aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/hwmon.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2008-07-29 23:49:16 +0000
committerJohn Crispin <blogic@openwrt.org>2008-07-29 23:49:16 +0000
commit44d115ed869fec16490d8cf671408e7fdbed2382 (patch)
treead56d1dbdf4e66e7f74b3d41df3cf06c5e249785 /package/kernel/modules/hwmon.mk
parenta155b9370d80b644189bd7cd9f17b736162b8b7d (diff)
downloadupstream-44d115ed869fec16490d8cf671408e7fdbed2382.tar.gz
upstream-44d115ed869fec16490d8cf671408e7fdbed2382.tar.bz2
upstream-44d115ed869fec16490d8cf671408e7fdbed2382.zip
add lm sensor and clean up dependency, fixes #3821
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11999 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/hwmon.mk')
-rw-r--r--package/kernel/modules/hwmon.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index 8ecf6cc8a9..943b4a7e82 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -30,7 +30,7 @@ $(eval $(call KernelPackage,hwmon-core))
define KernelPackage/hwmon-lm77
SUBMENU:=$(HWMON_MENU)
TITLE:=LM77 monitoring support
- DEPENDS:=kmod-hwmon-core kmod-i2c-core
+ DEPENDS:=kmod-hwmon-core +kmod-i2c-core
KCONFIG:=CONFIG_SENSORS_LM77
FILES:=$(LINUX_DIR)/drivers/hwmon/lm77.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,60,lm77)
@@ -42,6 +42,20 @@ endef
$(eval $(call KernelPackage,hwmon-lm77))
+define KernelPackage/hwmon-lm90
+ SUBMENU:=$(HWMON_MENU)
+ TITLE:=LM90 monitoring support
+ DEPENDS:=kmod-hwmon-core +kmod-i2c-core
+ KCONFIG:=CONFIG_SENSORS_LM90
+ FILES:=$(LINUX_DIR)/drivers/hwmon/lm90.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,60,lm90)
+endef
+
+define KernelPackage/hwmon-lm90/description
+ Kernel module for LM90 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm90))
define KernelPackage/hwmon-pc87360
SUBMENU:=$(HWMON_MENU)