aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/001-depends.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-06-21 16:54:37 +0000
committerJohn Crispin <blogic@openwrt.org>2013-06-21 16:54:37 +0000
commitf1b4824c865b228039d84b2605b2e7e4f34cddeb (patch)
tree37c9cbe251e4fb790aaa72e862c35822be30b491 /package/kernel/modules/001-depends.mk
parentd2642de7494bba312bbb22cfeb3ad77130a10047 (diff)
downloadupstream-f1b4824c865b228039d84b2605b2e7e4f34cddeb.tar.gz
upstream-f1b4824c865b228039d84b2605b2e7e4f34cddeb.tar.bz2
upstream-f1b4824c865b228039d84b2605b2e7e4f34cddeb.zip
packages: clean up the package folder
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37007 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/001-depends.mk')
-rw-r--r--package/kernel/modules/001-depends.mk37
1 files changed, 0 insertions, 37 deletions
diff --git a/package/kernel/modules/001-depends.mk b/package/kernel/modules/001-depends.mk
deleted file mode 100644
index e0af735705..0000000000
--- a/package/kernel/modules/001-depends.mk
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# Copyright (C) 2010-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define AddDepends/crc16
- DEPENDS+= +kmod-lib-crc16 $(1)
-endef
-
-define AddDepends/hid
- DEPENDS+= +kmod-hid $(1)
-endef
-
-define AddDepends/input
- DEPENDS+= +kmod-input-core $(1)
-endef
-
-
-define AddDepends/nls
- DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
-endef
-
-
-define SetDepends/rfkill
- DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx)
-endef
-
-define AddDepends/rfkill
- DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_cns3xxx||TARGET_ixp4xx):kmod-rfkill $(1)
-endef
-
-
-define AddDepends/rtc
- DEPENDS+= @RTC_SUPPORT
-endef