aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/001-depends.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-24 12:29:50 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-24 12:29:50 +0000
commit8881258e0bca6eff1b6103b2618f385e7c35d982 (patch)
tree9aed144bc67975e17e7e5ef84d50ed06d2d2f5d0 /package/kernel/modules/001-depends.mk
parent360dabaaae0b8cd5198e2277ca164f8a5bc9a315 (diff)
downloadupstream-8881258e0bca6eff1b6103b2618f385e7c35d982.tar.gz
upstream-8881258e0bca6eff1b6103b2618f385e7c35d982.tar.bz2
upstream-8881258e0bca6eff1b6103b2618f385e7c35d982.zip
package/kernel: allow additional dependencies as arguments to AddDepends macros
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21128 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/001-depends.mk')
-rw-r--r--package/kernel/modules/001-depends.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/kernel/modules/001-depends.mk b/package/kernel/modules/001-depends.mk
index 5cb3412081..61d892198e 100644
--- a/package/kernel/modules/001-depends.mk
+++ b/package/kernel/modules/001-depends.mk
@@ -12,7 +12,7 @@ define SetDepends/crc16
endef
define AddDepends/crc16
- DEPENDS+= +!TARGET_xburst:kmod-crc16
+ DEPENDS+= +!TARGET_xburst:kmod-crc16 $(1)
endef
@@ -21,7 +21,7 @@ define SetDepends/hid
endef
define AddDepends/hid
- DEPENDS+= +!TARGET_x86:kmod-hid
+ DEPENDS+= +!TARGET_x86:kmod-hid $(1)
endef
@@ -31,7 +31,7 @@ define SetDepends/input
endef
define AddDepends/input
- DEPENDS+= +!TARGET_x86:kmod-input-core
+ DEPENDS+= +!TARGET_x86:kmod-input-core $(1)
endef
@@ -40,6 +40,5 @@ define SetDepends/rfkill
endef
define AddDepends/rfkill
- DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill
-
+ DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
endef