aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2022-12-24 14:39:17 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-12-24 15:14:58 +0100
commitcb7d662dac897dd7df6ba6ba60417db822bd68f2 (patch)
treecf99b3000968338e870b2c4445ff3f24703f7be4 /package/kernel/mac80211
parentb4da12c2a0609975cf5ae03d3deb92012bf9e784 (diff)
downloadupstream-cb7d662dac897dd7df6ba6ba60417db822bd68f2.tar.gz
upstream-cb7d662dac897dd7df6ba6ba60417db822bd68f2.tar.bz2
upstream-cb7d662dac897dd7df6ba6ba60417db822bd68f2.zip
mac80211: Do not build brcmsmac on bcm47xx_legacy
brcmsmac needs bcma. bcma is build into the kernel for the other bcm47xx subtargets, but not for the legacy target because it only uses ssb. We could build bcma as a module for bcm47xx_legacy, but none of these old devices uses a wifi card supported by brcsmac. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel/mac80211')
-rw-r--r--package/kernel/mac80211/broadcom.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/mac80211/broadcom.mk b/package/kernel/mac80211/broadcom.mk
index 67599acbad..90167941c4 100644
--- a/package/kernel/mac80211/broadcom.mk
+++ b/package/kernel/mac80211/broadcom.mk
@@ -381,7 +381,7 @@ define KernelPackage/brcmsmac
$(call KernelPackage/mac80211/Default)
TITLE:=Broadcom IEEE802.11n PCIe SoftMAC WLAN driver
URL:=https://wireless.wiki.kernel.org/en/users/drivers/brcm80211
- DEPENDS+= +kmod-mac80211 +!TARGET_bcm47xx:kmod-bcma +kmod-lib-cordic +kmod-lib-crc8 +kmod-brcmutil +!BRCMSMAC_USE_FW_FROM_WL:brcmsmac-firmware
+ DEPENDS+=@!TARGET_bcm47xx_legacy +kmod-mac80211 +!TARGET_bcm47xx:kmod-bcma +kmod-lib-cordic +kmod-lib-crc8 +kmod-brcmutil +!BRCMSMAC_USE_FW_FROM_WL:brcmsmac-firmware
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/broadcom/brcm80211/brcmsmac/brcmsmac.ko
AUTOLOAD:=$(call AutoProbe,brcmsmac)
MENU:=1