aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-07 15:42:54 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-14 14:10:51 +0100
commit8fe5ad5d3373cebed4fbc55a7b779721971ce427 (patch)
tree5d9106ede800508dde24c21dda7f90b8b1b8af5b /package/kernel/mac80211
parent8590e70fab64172700c21bc5e658eba17a1eae70 (diff)
downloadupstream-8fe5ad5d3373cebed4fbc55a7b779721971ce427.tar.gz
upstream-8fe5ad5d3373cebed4fbc55a7b779721971ce427.tar.bz2
upstream-8fe5ad5d3373cebed4fbc55a7b779721971ce427.zip
brcm47xx: rename target to bcm47xx
This change makes the names of Broadcom targets consistent by using the common notation based on SoC/CPU ID (which is used internally anyway), bcmXXXX instead of brcmXXXX. This is even used for target TITLE in make menuconfig already, only the short target name used brcm so far. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/kernel/mac80211')
-rw-r--r--package/kernel/mac80211/broadcom.mk28
1 files changed, 14 insertions, 14 deletions
diff --git a/package/kernel/mac80211/broadcom.mk b/package/kernel/mac80211/broadcom.mk
index a54f17a61a..74d6b8d6ce 100644
--- a/package/kernel/mac80211/broadcom.mk
+++ b/package/kernel/mac80211/broadcom.mk
@@ -118,14 +118,14 @@ define KernelPackage/b43/config
config PACKAGE_B43_USE_SSB
select PACKAGE_kmod-ssb
tristate
- depends on !TARGET_brcm47xx && !TARGET_brcm63xx
+ depends on !TARGET_bcm47xx && !TARGET_brcm63xx
default PACKAGE_kmod-b43 if PACKAGE_B43_BUSES_BCMA_AND_SSB
default PACKAGE_kmod-b43 if PACKAGE_B43_BUSES_SSB
config PACKAGE_B43_USE_BCMA
select PACKAGE_kmod-bcma
tristate
- depends on !TARGET_brcm47xx && !TARGET_bcm53xx
+ depends on !TARGET_bcm47xx && !TARGET_bcm53xx
default PACKAGE_kmod-b43 if PACKAGE_B43_BUSES_BCMA_AND_SSB
default PACKAGE_kmod-b43 if PACKAGE_B43_BUSES_BCMA
@@ -205,8 +205,8 @@ config PACKAGE_B43_USE_BCMA
config B43_FW_SQUASH_COREREVS
string "Core revisions to include"
depends on B43_FW_SQUASH
- default "5,6,7,8,9,10,11,13,15" if TARGET_brcm47xx_legacy
- default "16,28,29,30" if TARGET_brcm47xx_mips74k
+ default "5,6,7,8,9,10,11,13,15" if TARGET_bcm47xx_legacy
+ default "16,28,29,30" if TARGET_bcm47xx_mips74k
default "5,6,7,8,9,10,11,13,15,16,28,29,30"
help
This is a comma seperated list of core revision numbers.
@@ -220,8 +220,8 @@ config PACKAGE_B43_USE_BCMA
config B43_FW_SQUASH_PHYTYPES
string "PHY types to include"
depends on B43_FW_SQUASH
- default "G,N,LP" if TARGET_brcm47xx_legacy
- default "N,HT" if TARGET_brcm47xx_mips74k
+ default "G,N,LP" if TARGET_bcm47xx_legacy
+ default "N,HT" if TARGET_bcm47xx_mips74k
default "G,N,LP,HT"
help
This is a comma seperated list of PHY types:
@@ -248,15 +248,15 @@ config PACKAGE_B43_USE_BCMA
This allows choosing buses that b43 should support.
config PACKAGE_B43_BUSES_BCMA_AND_SSB
- depends on !TARGET_brcm47xx_legacy && !TARGET_brcm47xx_mips74k && !TARGET_bcm53xx
+ depends on !TARGET_bcm47xx_legacy && !TARGET_bcm47xx_mips74k && !TARGET_bcm53xx
bool "BCMA and SSB"
config PACKAGE_B43_BUSES_BCMA
- depends on !TARGET_brcm47xx_legacy
+ depends on !TARGET_bcm47xx_legacy
bool "BCMA only"
config PACKAGE_B43_BUSES_SSB
- depends on !TARGET_brcm47xx_mips74k && !TARGET_bcm53xx
+ depends on !TARGET_bcm47xx_mips74k && !TARGET_bcm53xx
bool "SSB only"
endchoice
@@ -281,7 +281,7 @@ config PACKAGE_B43_USE_BCMA
config PACKAGE_B43_PHY_G
bool "Enable support for G-PHYs"
- default n if TARGET_brcm47xx_mips74k
+ default n if TARGET_bcm47xx_mips74k
default y
help
Enable support for G-PHY. This includes support for the following devices:
@@ -304,7 +304,7 @@ config PACKAGE_B43_USE_BCMA
config PACKAGE_B43_PHY_LP
bool "Enable support for LP-PHYs"
- default n if TARGET_brcm47xx_mips74k
+ default n if TARGET_bcm47xx_mips74k
default y
help
Enable support for LP-PHY. This includes support for the following devices:
@@ -315,7 +315,7 @@ config PACKAGE_B43_USE_BCMA
config PACKAGE_B43_PHY_HT
bool "Enable support for HT-PHYs"
- default n if TARGET_brcm47xx_legacy
+ default n if TARGET_bcm47xx_legacy
default y
help
Enable support for HT-PHY. This includes support for the following devices:
@@ -347,7 +347,7 @@ define KernelPackage/b43legacy
URL:=https://wireless.wiki.kernel.org/en/users/drivers/b43
KCONFIG:= \
CONFIG_HW_RANDOM=y
- DEPENDS+= +kmod-mac80211 +!(TARGET_brcm47xx||TARGET_brcm63xx):kmod-ssb @!TARGET_brcm47xx_mips74k +b43legacy-firmware
+ DEPENDS+= +kmod-mac80211 +!(TARGET_bcm47xx||TARGET_brcm63xx):kmod-ssb @!TARGET_bcm47xx_mips74k +b43legacy-firmware
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/broadcom/b43legacy/b43legacy.ko
AUTOLOAD:=$(call AutoProbe,b43legacy)
MENU:=1
@@ -401,7 +401,7 @@ define KernelPackage/brcmsmac
$(call KernelPackage/mac80211/Default)
TITLE:=Broadcom IEEE802.11n PCIe SoftMAC WLAN driver
URL:=https://wireless.wiki.kernel.org/en/users/drivers/brcm80211
- DEPENDS+= +kmod-mac80211 +@DRIVER_11N_SUPPORT +!TARGET_brcm47xx:kmod-bcma +kmod-lib-cordic +kmod-lib-crc8 +kmod-brcmutil +!BRCMSMAC_USE_FW_FROM_WL:brcmsmac-firmware
+ DEPENDS+= +kmod-mac80211 +@DRIVER_11N_SUPPORT +!TARGET_bcm47xx:kmod-bcma +kmod-lib-cordic +kmod-lib-crc8 +kmod-brcmutil +!BRCMSMAC_USE_FW_FROM_WL:brcmsmac-firmware
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/broadcom/brcm80211/brcmsmac/brcmsmac.ko
AUTOLOAD:=$(call AutoProbe,brcmsmac)
MENU:=1