aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211
diff options
context:
space:
mode:
authorLorenzo Santina <lorenzo.santina@edu.unito.it>2017-09-11 15:27:53 +0200
committerMathias Kresin <dev@kresin.me>2017-09-13 08:07:39 +0200
commitd33f7905dfb39458ff2127237be22a54e806bdc9 (patch)
treeccbf9c3f1bb3aa3a29aeaf0bc43f425352c8950a /package/kernel/mac80211
parent4f162ac3ce3c37fa15561cc3de6a044ff3ace2bc (diff)
downloadupstream-d33f7905dfb39458ff2127237be22a54e806bdc9.tar.gz
upstream-d33f7905dfb39458ff2127237be22a54e806bdc9.tar.bz2
upstream-d33f7905dfb39458ff2127237be22a54e806bdc9.zip
treewide: fix shellscript syntax errors/typos
Fix multiple syntax errors in shelscripts (of packages only) These errors were causing many conditions to not working properly Signed-off-by: Lorenzo Santina <lorenzo.santina@edu.unito.it> [increase PKG_RELEASE, drop command substitution from directip.sh] Signed-off-by: Mathias Kresin <dev@kresin.em>
Diffstat (limited to 'package/kernel/mac80211')
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--package/kernel/mac80211/files/lib/wifi/mac80211.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 8ec05a343a..3a96472b88 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_VERSION:=2017-01-31
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
PKG_BACKPORT_VERSION:=
PKG_HASH:=75e6d39e34cf156212a2509172a4a62b673b69eb4a1d9aaa565f7fa719fa2317
diff --git a/package/kernel/mac80211/files/lib/wifi/mac80211.sh b/package/kernel/mac80211/files/lib/wifi/mac80211.sh
index 4bfc7424b2..940fb52ac2 100644
--- a/package/kernel/mac80211/files/lib/wifi/mac80211.sh
+++ b/package/kernel/mac80211/files/lib/wifi/mac80211.sh
@@ -92,7 +92,7 @@ detect_mac80211() {
htmode="VHT80"
}
- [ -n $htmode ] && ht_capab="set wireless.radio${devidx}.htmode=$htmode"
+ [ -n "$htmode" ] && ht_capab="set wireless.radio${devidx}.htmode=$htmode"
if [ -x /usr/bin/readlink -a -h /sys/class/ieee80211/${dev} ]; then
path="$(readlink -f /sys/class/ieee80211/${dev}/device)"