aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/marvell.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-09-29 20:13:55 +0200
committerFelix Fietkau <nbd@nbd.name>2018-10-06 13:02:29 +0200
commit502bcd93fe3308e9dff39c5941606fc64807d46d (patch)
tree38ecc438f0b7d73cb293b2621ec74636647104ed /package/kernel/mac80211/marvell.mk
parent2804a7f13e119d337d84047ca2ac6577ab814406 (diff)
downloadupstream-502bcd93fe3308e9dff39c5941606fc64807d46d.tar.gz
upstream-502bcd93fe3308e9dff39c5941606fc64807d46d.tar.bz2
upstream-502bcd93fe3308e9dff39c5941606fc64807d46d.zip
mac80211: move marvell packaging code to marvell.mk
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/mac80211/marvell.mk')
-rw-r--r--package/kernel/mac80211/marvell.mk90
1 files changed, 90 insertions, 0 deletions
diff --git a/package/kernel/mac80211/marvell.mk b/package/kernel/mac80211/marvell.mk
new file mode 100644
index 0000000000..4e2f925b73
--- /dev/null
+++ b/package/kernel/mac80211/marvell.mk
@@ -0,0 +1,90 @@
+PKG_DRIVERS += \
+ libertas-sdio libertas-usb libertas-spi \
+ mwl8k mwifiex-pcie mwifiex-sdio
+
+config-$(call config_package,libertas-sdio) += LIBERTAS LIBERTAS_SDIO
+config-$(call config_package,libertas-usb) += LIBERTAS LIBERTAS_USB
+config-$(call config_package,libertas-spi) += LIBERTAS LIBERTAS_SPI
+config-$(call config_package,mwl8k) += MWL8K
+config-$(call config_package,mwifiex-pcie) += MWIFIEX MWIFIEX_PCIE
+config-$(call config_package,mwifiex-sdio) += MWIFIEX MWIFIEX_SDIO
+
+define KernelPackage/libertas-usb
+ $(call KernelPackage/mac80211/Default)
+ DEPENDS+= @USB_SUPPORT +kmod-cfg80211 +kmod-usb-core +kmod-lib80211 +@DRIVER_WEXT_SUPPORT +libertas-usb-firmware @!LINUX_3_18
+ TITLE:=Marvell 88W8015 Wireless Driver
+ FILES:= \
+ $(PKG_BUILD_DIR)/drivers/net/wireless/marvell/libertas/libertas.ko \
+ $(PKG_BUILD_DIR)/drivers/net/wireless/marvell/libertas/usb8xxx.ko
+ AUTOLOAD:=$(call AutoProbe,libertas usb8xxx)
+endef
+
+define KernelPackage/libertas-sdio
+ $(call KernelPackage/mac80211/Default)
+ DEPENDS+= +kmod-cfg80211 +kmod-lib80211 +kmod-mmc +@DRIVER_WEXT_SUPPORT @!TARGET_uml +libertas-sdio-firmware @!LINUX_3_18
+ TITLE:=Marvell 88W8686 Wireless Driver
+ FILES:= \
+ $(PKG_BUILD_DIR)/drivers/net/wireless/marvell/libertas/libertas.ko \
+ $(PKG_BUILD_DIR)/drivers/net/wireless/marvell/libertas/libertas_sdio.ko
+ AUTOLOAD:=$(call AutoProbe,libertas libertas_sdio)
+endef
+
+define KernelPackage/libertas-spi
+ $(call KernelPackage/mac80211/Default)
+ SUBMENU:=Wireless Drivers
+ DEPENDS+= +kmod-cfg80211 +kmod-lib80211 +@DRIVER_WEXT_SUPPORT @!TARGET_uml +libertas-spi-firmware @!LINUX_3_18
+ KCONFIG := \
+ CONFIG_SPI=y \
+ CONFIG_SPI_MASTER=y
+ TITLE:=Marvell 88W8686 SPI Wireless Driver
+ FILES:= \
+ $(PKG_BUILD_DIR)/drivers/net/wireless/marvell/libertas/libertas.ko \
+ $(PKG_BUILD_DIR)/drivers/net/wireless/marvell/libertas/libertas_spi.ko
+ AUTOLOAD:=$(call AutoProbe,libertas libertas_spi)
+endef
+
+
+define KernelPackage/mwl8k
+ $(call KernelPackage/mac80211/Default)
+ TITLE:=Driver for Marvell TOPDOG 802.11 Wireless cards
+ URL:=https://wireless.wiki.kernel.org/en/users/drivers/mwl8k
+ DEPENDS+= @PCI_SUPPORT +kmod-mac80211 +@DRIVER_11N_SUPPORT +mwl8k-firmware
+ FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/marvell/mwl8k.ko
+ AUTOLOAD:=$(call AutoProbe,mwl8k)
+endef
+
+define KernelPackage/mwl8k/description
+ Kernel modules for Marvell TOPDOG 802.11 Wireless cards
+endef
+
+
+define KernelPackage/mwifiex-pcie
+ $(call KernelPackage/mac80211/Default)
+ TITLE:=Driver for Marvell 802.11n/802.11ac PCIe Wireless cards
+ URL:=https://wireless.wiki.kernel.org/en/users/drivers/mwifiex
+ DEPENDS+= @PCI_SUPPORT +kmod-mac80211 +@DRIVER_11N_SUPPORT +@DRIVER_11AC_SUPPORT +mwifiex-pcie-firmware
+ FILES:= \
+ $(PKG_BUILD_DIR)/drivers/net/wireless/marvell/mwifiex/mwifiex.ko \
+ $(PKG_BUILD_DIR)/drivers/net/wireless/marvell/mwifiex/mwifiex_pcie.ko
+ AUTOLOAD:=$(call AutoProbe,mwifiex_pcie)
+endef
+
+define KernelPackage/mwifiex-pcie/description
+ Kernel modules for Marvell 802.11n/802.11ac PCIe Wireless cards
+endef
+
+define KernelPackage/mwifiex-sdio
+ $(call KernelPackage/mac80211/Default)
+ TITLE:=Driver for Marvell 802.11n/802.11ac SDIO Wireless cards
+ URL:=https://wireless.wiki.kernel.org/en/users/drivers/mwifiex
+ DEPENDS+= +kmod-mmc +kmod-mac80211 +@DRIVER_11N_SUPPORT +@DRIVER_11AC_SUPPORT +mwifiex-sdio-firmware
+ FILES:= \
+ $(PKG_BUILD_DIR)/drivers/net/wireless/marvell/mwifiex/mwifiex.ko \
+ $(PKG_BUILD_DIR)/drivers/net/wireless/marvell/mwifiex/mwifiex_sdio.ko
+ AUTOLOAD:=$(call AutoProbe,mwifiex_sdio)
+endef
+
+define KernelPackage/mwifiex-sdio/description
+ Kernel modules for Marvell 802.11n/802.11ac SDIO Wireless cards
+endef
+