aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/broadcom.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-10-12 12:54:30 +0200
committerFelix Fietkau <nbd@nbd.name>2022-11-09 20:44:28 +0100
commita06e023b4e124dad2b2ddf3db87cb804b7043b26 (patch)
tree64a3dfcbc4ae2692c2670f37392e7955dc5d8c56 /package/kernel/mac80211/broadcom.mk
parentf753316f4aa4764e80c4dbf6f2cc88922052da1e (diff)
downloadupstream-a06e023b4e124dad2b2ddf3db87cb804b7043b26.tar.gz
upstream-a06e023b4e124dad2b2ddf3db87cb804b7043b26.tar.bz2
upstream-a06e023b4e124dad2b2ddf3db87cb804b7043b26.zip
mac80211: remove old legacy legacy drivers
Get rid of drivers that are either limited to 802.11b/g or don't even support cfg80211/mac80211. Most of these are either limited to boards that we don't even support anymore because of firmware size, or were only used for custom hacks by a really small number of users in the past. Let's get rid of those to reduce the maintenance effort and the number of useless packages Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/mac80211/broadcom.mk')
-rw-r--r--package/kernel/mac80211/broadcom.mk22
1 files changed, 1 insertions, 21 deletions
diff --git a/package/kernel/mac80211/broadcom.mk b/package/kernel/mac80211/broadcom.mk
index 5548f6e661..b426ec2b19 100644
--- a/package/kernel/mac80211/broadcom.mk
+++ b/package/kernel/mac80211/broadcom.mk
@@ -1,5 +1,5 @@
PKG_DRIVERS += \
- b43 b43legacy brcmsmac brcmfmac brcmutil
+ b43 brcmsmac brcmfmac brcmutil
PKG_CONFIG_DEPENDS += \
CONFIG_PACKAGE_B43_DEBUG \
@@ -24,9 +24,6 @@ config-$(CONFIG_PACKAGE_B43_PHY_HT) += B43_PHY_HT
config-$(CONFIG_PACKAGE_B43_PIO) += B43_PIO
config-$(CONFIG_PACKAGE_B43_DEBUG) += B43_DEBUG
-config-$(call config_package,b43legacy) += B43LEGACY
-config-y += B43LEGACY_DMA_MODE
-
config-$(call config_package,brcmutil) += BRCMUTIL
config-$(call config_package,brcmsmac) += BRCMSMAC
config-$(call config_package,brcmfmac) += BRCMFMAC
@@ -341,23 +338,6 @@ define KernelPackage/b43/description
Kernel module for Broadcom 43xx wireless support (mac80211 stack) new
endef
-define KernelPackage/b43legacy
- $(call KernelPackage/mac80211/Default)
- TITLE:=Broadcom 43xx-legacy wireless support
- URL:=https://wireless.wiki.kernel.org/en/users/drivers/b43
- KCONFIG:= \
- CONFIG_HW_RANDOM=y
- DEPENDS+= +kmod-mac80211 +!(TARGET_bcm47xx||TARGET_bcm63xx):kmod-ssb @!TARGET_bcm47xx_mips74k +b43legacy-firmware
- FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/broadcom/b43legacy/b43legacy.ko
- AUTOLOAD:=$(call AutoProbe,b43legacy)
- MENU:=1
-endef
-
-define KernelPackage/b43legacy/description
-Kernel module for Broadcom 43xx-legacy wireless support (mac80211 stack) new
-endef
-
-
define KernelPackage/brcmutil
$(call KernelPackage/mac80211/Default)
TITLE:=Broadcom IEEE802.11n common driver parts