aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/ath.mk
diff options
context:
space:
mode:
authorTiago Gaspar <tiagogaspar8@gmail.com>2022-06-23 14:15:06 +0100
committerChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-06-27 21:33:16 +0200
commit40c2cd8bd0f7e7b6553d47c11dacb48acc533863 (patch)
tree59f34b6b027a80a757f6941ca23746a66b8b57e9 /package/kernel/mac80211/ath.mk
parent9d06e5a7735508d793c3a125f9f7d623671e29e4 (diff)
downloadupstream-40c2cd8bd0f7e7b6553d47c11dacb48acc533863.tar.gz
upstream-40c2cd8bd0f7e7b6553d47c11dacb48acc533863.tar.bz2
upstream-40c2cd8bd0f7e7b6553d47c11dacb48acc533863.zip
ath10k: enable encapsulation offload by default
Enable ath10k offload by default. This improves wireless performance without requiring user configuration. This adds ath10k_core to the AUTOLOAD section so that the frame_mode paramter can be added to /etc/modules.d and passed to the driver. The frame_mode 2 enables ethernet mode on the firmware/driver. This parameter is set by passing a different value to the frame_mode value on kmod insmod. Link to the original patchset: https://patchwork.kernel.org/project/linux-wireless/cover/20220516032519.29831-1-ryazanov.s.a@gmail.com/ Signed-off-by: Tiago Gaspar <tiagogaspar8@gmail.com>
Diffstat (limited to 'package/kernel/mac80211/ath.mk')
-rw-r--r--package/kernel/mac80211/ath.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/mac80211/ath.mk b/package/kernel/mac80211/ath.mk
index 50b1eed9c8..9af8c4665d 100644
--- a/package/kernel/mac80211/ath.mk
+++ b/package/kernel/mac80211/ath.mk
@@ -260,7 +260,8 @@ define KernelPackage/ath10k
FILES:= \
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath10k/ath10k_core.ko \
$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath10k/ath10k_pci.ko
- AUTOLOAD:=$(call AutoProbe,ath10k_pci)
+ AUTOLOAD:=$(call AutoProbe,ath10k_core ath10k_pci)
+ MODPARAMS.ath10k_core:=frame_mode=2
VARIANT:=regular
endef