aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/ath.mk
diff options
context:
space:
mode:
authorRobert Marko <robimarko@gmail.com>2022-12-13 23:55:26 +0100
committerRobert Marko <robimarko@gmail.com>2023-01-16 12:42:23 +0100
commit35f28f2838948e33f46c60b966a48a7e78ae8743 (patch)
treead56989de04f8e1f6ca85f49e8b39ec56f76e98b /package/kernel/mac80211/ath.mk
parent4359d10b0112127d8c0835ee670e4de3952ae0b2 (diff)
downloadupstream-35f28f2838948e33f46c60b966a48a7e78ae8743.tar.gz
upstream-35f28f2838948e33f46c60b966a48a7e78ae8743.tar.bz2
upstream-35f28f2838948e33f46c60b966a48a7e78ae8743.zip
mac80211: add ath11k AHB support
This is the follow up to the PCI support commit now providing support for AHB variant as well, though currently only for ipq807x as that is only OpenWrt supported SoC ath11k supports as well. Currently, we are disabling coldboot calibration on ipq807x as it does not work, there is a remoteproc bug that makes it come late out of reset so disable coldboot until that is fixed. Also, as ath11k is quite memory hungry, we are introducing a config option to use the limits for 512MB of RAM, similar to what QCA does downstream but in way simpler and cleaner way so that 512MB save some RAM. 512MB profile is also set as the default for now. Signed-off-by: Robert Marko <robimarko@gmail.com>
Diffstat (limited to 'package/kernel/mac80211/ath.mk')
-rw-r--r--package/kernel/mac80211/ath.mk18
1 files changed, 17 insertions, 1 deletions
diff --git a/package/kernel/mac80211/ath.mk b/package/kernel/mac80211/ath.mk
index 83228311cc..4f14fec8e2 100644
--- a/package/kernel/mac80211/ath.mk
+++ b/package/kernel/mac80211/ath.mk
@@ -1,6 +1,6 @@
PKG_DRIVERS += \
ath ath5k ath6kl ath6kl-sdio ath6kl-usb ath9k ath9k-common ath9k-htc ath10k ath10k-smallbuffers \
- ath11k ath11k-pci carl9170 owl-loader ar5523 wil6210
+ ath11k ath11k-ahb ath11k-pci carl9170 owl-loader ar5523 wil6210
PKG_CONFIG_DEPENDS += \
CONFIG_PACKAGE_ATH_DEBUG \
@@ -61,6 +61,7 @@ config-$(call config_package,ath9k-htc) += ATH9K_HTC
config-$(call config_package,ath10k) += ATH10K ATH10K_PCI
config-$(call config_package,ath10k-smallbuffers) += ATH10K ATH10K_PCI ATH10K_SMALLBUFFERS
config-$(call config_package,ath11k) += ATH11K
+config-$(call config_package,ath11k-ahb) += ATH11K_AHB
config-$(call config_package,ath11k-pci) += ATH11K_PCI
config-$(call config_package,ath5k) += ATH5K
@@ -316,9 +317,24 @@ define KernelPackage/ath11k/config
config ATH11K_THERMAL
bool "Enable thermal sensors and throttling support"
depends on PACKAGE_kmod-ath11k
+ default y if TARGET_ipq807x
endef
+define KernelPackage/ath11k-ahb
+ $(call KernelPackage/mac80211/Default)
+ TITLE:=Qualcomm 802.11ax AHB wireless chipset support
+ URL:=https://wireless.wiki.kernel.org/en/users/drivers/ath11k
+ DEPENDS+= @TARGET_ipq807x +kmod-ath11k +kmod-qrtr-smd
+ FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ath/ath11k/ath11k_ahb.ko
+ AUTOLOAD:=$(call AutoProbe,ath11k_ahb)
+endef
+
+define KernelPackage/ath11k-ahb/description
+This module adds support for Qualcomm Technologies 802.11ax family of
+chipsets with AHB bus.
+endef
+
define KernelPackage/ath11k-pci
$(call KernelPackage/mac80211/Default)
TITLE:=Qualcomm 802.11ax PCI wireless chipset support