aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-05-25 22:39:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-05-25 22:39:58 +0000
commit39270a81ac78eab924181835a31d57977d117a2f (patch)
tree6c8542aa132c45dfed010c8b009706b938d40af0 /package/kernel/mac80211/Makefile
parent72aad7a99113dda9420eec8f5a5af2463b5d65cf (diff)
downloadupstream-39270a81ac78eab924181835a31d57977d117a2f.tar.gz
upstream-39270a81ac78eab924181835a31d57977d117a2f.tar.bz2
upstream-39270a81ac78eab924181835a31d57977d117a2f.zip
ath9k: make support for PC-OEM cards optional, reduces module size
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40859 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 60a12205ac..8edf0d2226 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -572,6 +572,14 @@ This module adds support for wireless adapters based on
Atheros IEEE 802.11n AR5008 and AR9001 family of chipsets.
endef
+define KernelPackage/ath9k/config
+
+ config ATH9K_SUPPORT_PCOEM
+ bool "Support chips used in PC OEM cards"
+ depends PACKAGE_kmod-ath9k
+
+endef
+
define KernelPackage/ath9k-htc
$(call KernelPackage/mac80211/Default)
TITLE:=Atheros 802.11n USB device support
@@ -1395,6 +1403,7 @@ config-$(call config_package,ath9k-common) += ATH9K_COMMON
config-$(CONFIG_TARGET_ar71xx) += ATH9K_AHB
config-$(CONFIG_PCI) += ATH9K_PCI
config-$(CONFIG_ATH_USER_REGD) += ATH_USER_REGD
+config-$(CONFIG_ATH9K_SUPPORT_PCOEM) += ATH9K_PCOEM
config-$(call config_package,ath9k-htc) += ATH9K_HTC
config-$(call config_package,ath10k) += ATH10K ATH10K_PCI