aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-11-15 18:54:06 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-11-15 18:54:06 +0100
commitfa845e9978ed49538d8c9c501792a0505c79b7d9 (patch)
treeb95b154ca050ea08227fa92bca2fbd1c22348995 /package/kernel/mac80211/Makefile
parenta250556d27556ec94a8d800fd27be40c2de8139c (diff)
downloadupstream-fa845e9978ed49538d8c9c501792a0505c79b7d9.tar.gz
upstream-fa845e9978ed49538d8c9c501792a0505c79b7d9.tar.bz2
upstream-fa845e9978ed49538d8c9c501792a0505c79b7d9.zip
ath9k: add support for the HSR tuner of the Ubiquiti UAP Outdoor+
Without setting the HSR to the selected channel, the WLAN of the UAP Outdoor+ will exhibit high packet loss in RX. Based-on-patch-by: Stefan Rompf <stefan@loplof.de> Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 25adbfbb90..52209137dd 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -251,6 +251,11 @@ define KernelPackage/ath9k/config
bool "Enable TX99 support"
depends on PACKAGE_kmod-ath9k
+ config ATH9K_UBNTHSR
+ bool "Support for Ubiquiti UniFi Outdoor+ access point"
+ depends on PACKAGE_kmod-ath9k && TARGET_ar71xx_generic
+ default y
+
endef
define KernelPackage/ath9k-htc
@@ -1503,6 +1508,7 @@ config-$(CONFIG_PCI) += ATH9K_PCI
config-$(CONFIG_ATH_USER_REGD) += ATH_USER_REGD
config-$(CONFIG_ATH9K_SUPPORT_PCOEM) += ATH9K_PCOEM
config-$(CONFIG_ATH9K_TX99) += ATH9K_TX99
+config-$(CONFIG_ATH9K_UBNTHSR) += ATH9K_UBNTHSR
config-$(call config_package,ath9k-htc) += ATH9K_HTC
config-$(call config_package,ath10k) += ATH10K ATH10K_PCI