aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2016-11-14 04:57:38 +0100
committerJohn Crispin <john@phrozen.org>2017-03-22 09:45:18 +0100
commitcc189c0b7fa015978b04bb663a75b1da726376b5 (patch)
treeaa24b17a11f709531894a52a51ef283c7be060ba /package/kernel/mac80211/Makefile
parentb015a841fca8ad4ded3275b803f3a97e45dcb41f (diff)
downloadupstream-cc189c0b7fa015978b04bb663a75b1da726376b5.tar.gz
upstream-cc189c0b7fa015978b04bb663a75b1da726376b5.tar.bz2
upstream-cc189c0b7fa015978b04bb663a75b1da726376b5.zip
mac80211: enable ath10k AHB support for QCA4019
This patch enables the ATH10K_AHB support for the QCA4019 devices on the AHB bus. This patch also removes 936-ath10k_skip_otp_check.patch because it breaks the AHB device identification. "Patch is wrong. I find it frustrating OpenWRT/LEDE doesn't try to work with upstream on ixing these things right." [1] <https://www.mail-archive.com/ath10k@lists.infradead.org/msg05896.html> It also limits ath10k memory hunger (This is a problem with 128MiB RAM) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 7d7065d4ec..679ea183d1 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1519,6 +1519,7 @@ config-$(CONFIG_PACKAGE_ATH_DFS) += ATH9K_DFS_CERTIFIED ATH10K_DFS_CERTIFIED
config-$(call config_package,ath9k) += ATH9K
config-$(call config_package,ath9k-common) += ATH9K_COMMON
config-$(CONFIG_TARGET_ar71xx) += ATH9K_AHB
+config-$(CONFIG_TARGET_ipq806x) += ATH10K_AHB
config-$(CONFIG_PCI) += ATH9K_PCI
config-$(CONFIG_ATH_USER_REGD) += ATH_USER_REGD
config-$(CONFIG_ATH9K_SUPPORT_PCOEM) += ATH9K_PCOEM