aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2016-11-10 15:28:17 +0300
committerJohn Crispin <john@phrozen.org>2016-11-16 10:54:33 +0100
commit84d57fc4857a6d60c328dd63a31e39475b66db80 (patch)
treecc2bacf2bad3c8c72a75287ed800a221e9f0dbaa /package/kernel/mac80211/Makefile
parent016520330440cb0aca4367150911721b748f75e8 (diff)
downloadupstream-84d57fc4857a6d60c328dd63a31e39475b66db80.tar.gz
upstream-84d57fc4857a6d60c328dd63a31e39475b66db80.tar.bz2
upstream-84d57fc4857a6d60c328dd63a31e39475b66db80.zip
mac80211: Make wlcore platform-independent
TI wl18xx and wl12xx are Wi-Fi/Bluetooth combo modules that could be found on different existing boards. But it is possible to get those modules as a separate component and use with existing boards as well as new boards equipped with either module may appear so we remove dependency on OMAP instead we add dependency on MMC because this Wi-Fi module uses SDIO interface. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Jo-Philipp Wich <jo@mein.io> Cc: Felix Fietkau <nbd@nbd.name> Cc: Imre Kaloz <kaloz@openwrt.org> Reviewed-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 52209137dd..93a91b1ab8 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1383,7 +1383,7 @@ endef
define KernelPackage/wlcore
$(call KernelPackage/mac80211/Default)
TITLE:=TI common driver part
- DEPENDS+= @TARGET_omap +kmod-mac80211 +@DRIVER_11N_SUPPORT
+ DEPENDS+= +kmod-mmc +kmod-mac80211 +@DRIVER_11N_SUPPORT
FILES:= \
$(PKG_BUILD_DIR)/drivers/net/wireless/ti/wlcore/wlcore.ko \
$(PKG_BUILD_DIR)/drivers/net/wireless/ti/wlcore/wlcore_sdio.ko