aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-24 15:36:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-24 15:36:08 +0000
commit5b76e57dc2e047a3e98401d3ef8d47f0c2f8a0ee (patch)
tree3053b32998ed53f5828439cb36f2802651d7da65 /package/kernel/mac80211/Makefile
parentbc0f9ad8ca4be62096bdf43a8cc5e1df989875a5 (diff)
downloadupstream-5b76e57dc2e047a3e98401d3ef8d47f0c2f8a0ee.tar.gz
upstream-5b76e57dc2e047a3e98401d3ef8d47f0c2f8a0ee.tar.bz2
upstream-5b76e57dc2e047a3e98401d3ef8d47f0c2f8a0ee.zip
kernel: remove kmod-crypto-aes, AES crypto support is always built into the kernel
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46483
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 3394fbe353..40b08c08dd 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -78,7 +78,7 @@ endef
define KernelPackage/mac80211
$(call KernelPackage/mac80211/Default)
TITLE:=Linux 802.11 Wireless Networking Stack
- DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-cfg80211 +hostapd-common
+ DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-cfg80211 +hostapd-common
KCONFIG:=\
CONFIG_AVERAGE=y
FILES:= $(PKG_BUILD_DIR)/net/mac80211/mac80211.ko
@@ -698,7 +698,7 @@ endef
define KernelPackage/net-libipw
$(call KernelPackage/mac80211/Default)
TITLE:=libipw for ipw2100 and ipw2200
- DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT
+ DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ipw2x00/libipw.ko
AUTOLOAD:=$(call AutoProbe,libipw)
endef