aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2022-08-29 16:22:18 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-09-07 21:21:38 +0200
commit6c4cd857851b010eab73fdefd4ada6b23f6eb048 (patch)
treeaf43708709c8ae213e413a124720b88a08d0b9a5 /package/kernel/linux
parenta99707d14c029cfa2d09c936418bb10316f76540 (diff)
downloadupstream-6c4cd857851b010eab73fdefd4ada6b23f6eb048.tar.gz
upstream-6c4cd857851b010eab73fdefd4ada6b23f6eb048.tar.bz2
upstream-6c4cd857851b010eab73fdefd4ada6b23f6eb048.zip
kernel: load FAT filesystem drivers before mount_root
Devices using GPT usually have FAT filesystem on boot partition and that's where the intermediary backup of system configuration is stored on sysupgrade. Automatic restoring of OpenWrt configuration after sysupgrade will be inhibited if the driver is not loaded and file system type is not specified in mount command. Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/fs.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index 0e4c0c091a..3ad458286f 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -601,7 +601,7 @@ define KernelPackage/fs-vfat
FILES:= \
$(LINUX_DIR)/fs/fat/fat.ko \
$(LINUX_DIR)/fs/fat/vfat.ko
- AUTOLOAD:=$(call AutoLoad,30,fat vfat)
+ AUTOLOAD:=$(call AutoLoad,30,fat vfat,1)
$(call AddDepends/nls,cp437 iso8859-1 utf8)
endef