aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-11-15 18:45:52 +0000
committerDaniel Golle <daniel@makrotopia.org>2022-11-15 19:12:39 +0000
commitebe2b7190b7d8815a588eaf8a5cfdf9edfd85c36 (patch)
tree65276f97a77ba26468154f2cbea969182127bc3b /package/kernel/linux
parent9a2d362bf7296d955b3cb8ab625bf1ec25703f89 (diff)
downloadupstream-ebe2b7190b7d8815a588eaf8a5cfdf9edfd85c36.tar.gz
upstream-ebe2b7190b7d8815a588eaf8a5cfdf9edfd85c36.tar.bz2
upstream-ebe2b7190b7d8815a588eaf8a5cfdf9edfd85c36.zip
kernel: modules: package Marvell gigE PHY driver
Some copper SFP modules come with Marvell's 88E1xxx PHY and need this module to function. Package it, so users can easily install this PHY driver and use e.g. FINISAR CORP. FCLF-8521-3-HC SFP. Without marvell PHY driver: sfp sfp2: module FINISAR CORP. FCLF-8521-3-HC rev A sn XXXXXXX dc XXXXXX mt7530 mdio-bus:1f sfp2: validation with support 0000000,00000000,00000000 failed: -22 sfp sfp2: sfp_add_phy failed: -22 With marvell PHY driver: sfp sfp2: module FINISAR CORP. FCLF-8521-3-HC rev A sn XXXXXXX dc XXXXXX mt7530 mdio-bus:1f sfp2: switched to inband/sgmii link mode mt7530 mdio-bus:1f sfp2: PHY [i2c:sfp2:16] driver [Marvell 88E1111] (irq=POLL) mt7530 mdio-bus:1f sfp2: Link is Up - 1Gbps/Full - flow control rx/tx Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/netdevices.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 394180902d..518d83f9a2 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -273,6 +273,40 @@ endef
$(eval $(call KernelPackage,phy-bcm84881))
+define KernelPackage/phy-marvell
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Marvell Gigabit Ethernet PHY driver
+ KCONFIG:=CONFIG_MARVELL_PHY
+ DEPENDS:=+kmod-libphy
+ FILES:=$(LINUX_DIR)/drivers/net/phy/marvell.ko
+ AUTOLOAD:=$(call AutoLoad,18,marvell)
+endef
+
+define KernelPackage/phy-marvell/description
+ Supports Marvell Gigabit Ethernet PHYs:
+ * 88E1101
+ * 88E1112
+ * 88E1111 (incl. Finisar variant)
+ * 88E1118
+ * 88E1121R
+ * 88E1145
+ * 88E1149R
+ * 88E1240
+ * 88E1318S
+ * 88E1116R
+ * 88E1510
+ * 88E1540
+ * 88E1545
+ * 88E3016
+ * 88E6341 family
+ * 88E6390 family
+ * 88E6393 family
+ * 88E1340S
+ * 88E1548P
+endef
+
+$(eval $(call KernelPackage,phy-marvell))
+
define KernelPackage/phy-realtek
SUBMENU:=$(NETWORK_DEVICES_MENU)