aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorUwe Kleine-König <uwe@kleine-koenig.org>2022-11-12 16:06:52 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-13 20:47:57 +0100
commitcec9cbef449daea6529fbda64777ff1b7ae4e499 (patch)
treeb41076e738e6d0aca61a35bc0c67e444b943f013 /package/kernel/linux
parentfdcd383919e9ba6a8f6558a1eff9abf7175e872e (diff)
downloadupstream-cec9cbef449daea6529fbda64777ff1b7ae4e499.tar.gz
upstream-cec9cbef449daea6529fbda64777ff1b7ae4e499.tar.bz2
upstream-cec9cbef449daea6529fbda64777ff1b7ae4e499.zip
kernel: add kmod-hwmon-sht3x support
The driver supports the temperature and humidity sensors chips SHT3x and STS3x by Sensirion. Signed-off-by: Uwe Kleine-König <uwe@kleine-koenig.org>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index e0810c97bd..c8d79b622e 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -474,6 +474,21 @@ endef
$(eval $(call KernelPackage,hwmon-sht21))
+define KernelPackage/hwmon-sht3x
+ TITLE:=Sensiron SHT3x and compat. monitoring support
+ KCONFIG:=CONFIG_SENSORS_SHT3x
+ FILES:=$(LINUX_DIR)/drivers/hwmon/sht3x.ko
+ AUTOLOAD:=$(call AutoProbe,sht3x)
+ $(call AddDepends/hwmon,+kmod-i2c-core +kmod-lib-crc8)
+endef
+
+define KernelPackage/hwmon-sht3x/description
+ Kernel module for Sensirion SHT3x temperature and humidity sensors chip
+endef
+
+$(eval $(call KernelPackage,hwmon-sht3x))
+
+
define KernelPackage/hwmon-tmp102
TITLE:=Texas Instruments TMP102 monitoring support
KCONFIG:=CONFIG_SENSORS_TMP102