aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorQuintin Hill <stuff@quintin.me.uk>2022-10-22 08:14:42 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-12 17:05:13 +0100
commitbc67c27283e1d0fa468c7fac5de9e864238305c7 (patch)
tree480daeaf67ba26f5ac96bef0e53d387dd9adf7db /package/kernel/linux
parent4979d16fb198c02a6f28a215c8827f98726824df (diff)
downloadupstream-bc67c27283e1d0fa468c7fac5de9e864238305c7.tar.gz
upstream-bc67c27283e1d0fa468c7fac5de9e864238305c7.tar.bz2
upstream-bc67c27283e1d0fa468c7fac5de9e864238305c7.zip
kernel: support for Realtek USB bluetooth devices
USB adaptors with the RTL8761B chipset are cheap and readily available but so far support is missing in Openwrt. Enable the relevant kernel options and add a module to the kmod-bluetooth package. Increases size of kmod-bluetooth ipk from 279140 bytes to 285320 bytes on my ath79 build. Tested on a WNDR3700v4 with rtl8761bu firmware. Signed-off-by: Quintin Hill <stuff@quintin.me.uk>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/other.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 46f5dea7ae..58dd2d6c25 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -41,7 +41,7 @@ define KernelPackage/bluetooth
CONFIG_BT_HCIBTUSB \
CONFIG_BT_HCIBTUSB_BCM=n \
CONFIG_BT_HCIBTUSB_MTK=y \
- CONFIG_BT_HCIBTUSB_RTL=n \
+ CONFIG_BT_HCIBTUSB_RTL=y \
CONFIG_BT_HCIUART \
CONFIG_BT_HCIUART_BCM=n \
CONFIG_BT_HCIUART_INTEL=n \
@@ -56,7 +56,8 @@ define KernelPackage/bluetooth
$(LINUX_DIR)/net/bluetooth/hidp/hidp.ko \
$(LINUX_DIR)/drivers/bluetooth/hci_uart.ko \
$(LINUX_DIR)/drivers/bluetooth/btusb.ko \
- $(LINUX_DIR)/drivers/bluetooth/btintel.ko
+ $(LINUX_DIR)/drivers/bluetooth/btintel.ko \
+ $(LINUX_DIR)/drivers/bluetooth/btrtl.ko
AUTOLOAD:=$(call AutoProbe,bluetooth rfcomm bnep hidp hci_uart btusb)
endef