aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2023-04-09 08:29:26 +0200
committerPetr Štetiar <ynezz@true.cz>2023-04-10 07:36:33 +0200
commit57392d63778b243c83f59c5e16436f4645b24a66 (patch)
treed7681ca4a766f5212a91eda1f8cc7f9fa17f1f8f /package/kernel/linux
parent8a554a287811eaf43f375b5875c87a75d1c9bcb0 (diff)
downloadupstream-57392d63778b243c83f59c5e16436f4645b24a66.tar.gz
upstream-57392d63778b243c83f59c5e16436f4645b24a66.tar.bz2
upstream-57392d63778b243c83f59c5e16436f4645b24a66.zip
kernel: crypto: fix missing dependecies for CRYPTO_USER_API_ENABLE_OBSOLETE
CRYPTO_USER_API_ENABLE_OBSOLETE config symbol depends on CRYPTO_USER so lets add this dependency to relevant modules. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/crypto.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 04499f5f5f..4950b94c62 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -52,6 +52,7 @@ $(eval $(call KernelPackage,crypto-aead))
define KernelPackage/crypto-arc4
TITLE:=ARC4 cipher CryptoAPI module
+ DEPENDS:=+kmod-crypto-user
KCONFIG:= \
CONFIG_CRYPTO_ARC4 \
CONFIG_CRYPTO_USER_API_ENABLE_OBSOLETE=y
@@ -678,7 +679,7 @@ $(eval $(call KernelPackage,crypto-michael-mic))
define KernelPackage/crypto-misc
TITLE:=Other CryptoAPI modules
- DEPENDS:=+kmod-crypto-xts
+ DEPENDS:=+kmod-crypto-xts +kmod-crypto-user
KCONFIG:= \
CONFIG_CRYPTO_USER_API_ENABLE_OBSOLETE=y \
CONFIG_CRYPTO_CAMELLIA_X86_64 \